aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/hs-zlib/Makefile
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2008-11-05 05:24:37 +0800
committerwxs <wxs@FreeBSD.org>2008-11-05 05:24:37 +0800
commit7f932517111417942e0f4f880a07f17815826c13 (patch)
treebe4644743075d67a7309c61944ac1d653b582117 /archivers/hs-zlib/Makefile
parent7769cb7dcb4f5f1f4a4fe4596879eb441eaf1a5d (diff)
downloadfreebsd-ports-gnome-7f932517111417942e0f4f880a07f17815826c13.tar.gz
freebsd-ports-gnome-7f932517111417942e0f4f880a07f17815826c13.tar.zst
freebsd-ports-gnome-7f932517111417942e0f4f880a07f17815826c13.zip
This package provides a pure interface for compressing and decompressing
streams of data represented as lazy ByteStrings. It uses the zlib C library so it has high performance. It supports the "zlib", "gzip" and "raw" compression formats. It provides a convenient high level api suitable for most tasks and for the few cases where more control is needed it provides access to the full zlib feature set. PR: ports/128552 Submitted by: Samy Al Bahra <sbahra@kerneled.org>
Diffstat (limited to 'archivers/hs-zlib/Makefile')
-rw-r--r--archivers/hs-zlib/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/archivers/hs-zlib/Makefile b/archivers/hs-zlib/Makefile
new file mode 100644
index 000000000000..aec9622e197b
--- /dev/null
+++ b/archivers/hs-zlib/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: zlib
+# Date created: November 2, 2008
+# Whom: Samy Al Bahra <sbahra@kerneled.org>
+#
+# $FreeBSD$
+
+PORTNAME= zlib
+PORTVERSION= 0.5.0.0
+CATEGORIES= archivers haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/ \
+ http://kerneled.org/tmp/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= sbahra@kerneled.org
+COMMENT= Pure Haskell interface to the C zlib library
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+CABAL= ${LOCALBASE}/bin/runghc Setup.hs
+GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${SUBDIR}
+
+do-configure:
+ cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+
+do-build:
+ cd ${WRKSRC} && ${CABAL} build && ${CABAL} register --gen-script
+
+do-install:
+ cd ${WRKSRC} && ${CABAL} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${SUBDIR}/register.sh
+
+.include <bsd.port.mk>