aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/libcabinet
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2002-10-26 10:55:52 +0800
committerkris <kris@FreeBSD.org>2002-10-26 10:55:52 +0800
commitb59c9e1e35103c446c8de55d829d77999e71b116 (patch)
tree0a5109baeef33f48f6f528cb1252154f3d38fa06 /archivers/libcabinet
parenta431715e60e09f7335ad90915bb088e486f6bfd1 (diff)
downloadfreebsd-ports-gnome-b59c9e1e35103c446c8de55d829d77999e71b116.tar.gz
freebsd-ports-gnome-b59c9e1e35103c446c8de55d829d77999e71b116.tar.zst
freebsd-ports-gnome-b59c9e1e35103c446c8de55d829d77999e71b116.zip
Mark BROKEN on 5.0
Diffstat (limited to 'archivers/libcabinet')
-rw-r--r--archivers/libcabinet/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/archivers/libcabinet/Makefile b/archivers/libcabinet/Makefile
index e49b87ee2be5..75e1fbe0e2f5 100644
--- a/archivers/libcabinet/Makefile
+++ b/archivers/libcabinet/Makefile
@@ -17,6 +17,12 @@ INSTALLS_SHLIB= yes
SRCFILE= ${WRKSRC}/listcab.cpp
PROGFILE= ${SRCFILE:S/.cpp$//}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500035
+BROKEN= "Does not compile on 5.0"
+.endif
+
post-build:
${CXX} ${CXXFLAGS} -o ${PROGFILE} ${SRCFILE} -L${WRKSRC} -lcabinet
@@ -26,4 +32,4 @@ pre-install:
post-install:
${INSTALL_PROGRAM} ${PROGFILE} ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>