aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/libdynamite
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-01-14 08:09:25 +0800
committeredwin <edwin@FreeBSD.org>2005-01-14 08:09:25 +0800
commit4e7609ecf21a6a750db876937797f54a1278c0b1 (patch)
treea337225315c3ca39e9cc9c7b23f993c7ec36b934 /archivers/libdynamite
parent6bd8eed27f20498edc99ef57171f99c56b03f4b2 (diff)
downloadfreebsd-ports-gnome-4e7609ecf21a6a750db876937797f54a1278c0b1.tar.gz
freebsd-ports-gnome-4e7609ecf21a6a750db876937797f54a1278c0b1.tar.zst
freebsd-ports-gnome-4e7609ecf21a6a750db876937797f54a1278c0b1.zip
[NEW PORT] archivers/dynamite: Decompress data compressed with
PKWARE Data Compression Library Dynamite is a tool and library for decompressing data compressed with the PKWARE Data Compression Library. WWW: http://synce.sourceforge.net Notes: * This library is required for the update of synce-kde * The 'dynamite' binary crashes when invoked without arguments. This is expected, not a freebsd specific problem. PR: ports/76026 Submitted by: Sam Lawrance <boris@brooknet.com.au>
Diffstat (limited to 'archivers/libdynamite')
-rw-r--r--archivers/libdynamite/Makefile30
-rw-r--r--archivers/libdynamite/distinfo2
-rw-r--r--archivers/libdynamite/pkg-descr4
-rw-r--r--archivers/libdynamite/pkg-plist7
4 files changed, 43 insertions, 0 deletions
diff --git a/archivers/libdynamite/Makefile b/archivers/libdynamite/Makefile
new file mode 100644
index 000000000000..514958e39a85
--- /dev/null
+++ b/archivers/libdynamite/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: dynamite
+# Date Created: 10 January 2005
+# Whom: Sam Lawrance <boris@brooknet.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dynamite
+PORTVERSION= 0.1
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= synce
+
+MAINTAINER= boris@brooknet.com.au
+COMMENT= Decompress data compressed with PKWARE Data Compression Library
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|' \
+ ${WRKSRC}/lib/libdynamite.c
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/archivers/libdynamite/distinfo b/archivers/libdynamite/distinfo
new file mode 100644
index 000000000000..9a7d8f6f43b4
--- /dev/null
+++ b/archivers/libdynamite/distinfo
@@ -0,0 +1,2 @@
+MD5 (dynamite-0.1.tar.gz) = 5e99d9172f60b8084cc6f6ba1a8c8261
+SIZE (dynamite-0.1.tar.gz) = 194544
diff --git a/archivers/libdynamite/pkg-descr b/archivers/libdynamite/pkg-descr
new file mode 100644
index 000000000000..edbaf5e0c5d5
--- /dev/null
+++ b/archivers/libdynamite/pkg-descr
@@ -0,0 +1,4 @@
+Dynamite is a tool and library for decompressing data compressed with the
+PKWARE Data Compression Library.
+
+WWW: http://synce.sourceforge.net
diff --git a/archivers/libdynamite/pkg-plist b/archivers/libdynamite/pkg-plist
new file mode 100644
index 000000000000..3cc01626100a
--- /dev/null
+++ b/archivers/libdynamite/pkg-plist
@@ -0,0 +1,7 @@
+bin/dynamite
+include/libdynamite.h
+lib/libdynamite.a
+lib/libdynamite.la
+lib/libdynamite.so
+lib/libdynamite.so.0
+share/aclocal/dynamite.m4