aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/liborange/Makefile
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2008-06-18 05:47:05 +0800
committeraraujo <araujo@FreeBSD.org>2008-06-18 05:47:05 +0800
commitef1053ebe6fc298b7f506ea89287e5d88a1ddf7d (patch)
treee7ba1274654276bd196ac1c4d5ab161e355bba4a /archivers/liborange/Makefile
parent593a4c8efc9faea515b4694d6ca4ee84d4efa3ab (diff)
downloadfreebsd-ports-gnome-ef1053ebe6fc298b7f506ea89287e5d88a1ddf7d.tar.gz
freebsd-ports-gnome-ef1053ebe6fc298b7f506ea89287e5d88a1ddf7d.tar.zst
freebsd-ports-gnome-ef1053ebe6fc298b7f506ea89287e5d88a1ddf7d.zip
- Repocopy archivers/orange to archivers/liborange.
- Update to 0.3.2. PR: ports/124402 Submitted by: Alexander Logvinov <ports@logvinov.com> (maintainer)
Diffstat (limited to 'archivers/liborange/Makefile')
-rw-r--r--archivers/liborange/Makefile64
1 files changed, 53 insertions, 11 deletions
diff --git a/archivers/liborange/Makefile b/archivers/liborange/Makefile
index 43daa055ef53..ce3c407b5f8a 100644
--- a/archivers/liborange/Makefile
+++ b/archivers/liborange/Makefile
@@ -5,26 +5,68 @@
# $FreeBSD$
#
-PORTNAME= orange
-PORTVERSION= 0.3
-PORTREVISION= 2
+PORTNAME= liborange
+PORTVERSION= 0.3.2
CATEGORIES= archivers
MASTER_SITES= SF
MASTER_SITE_SUBDIR= synce
MAINTAINER= ports@logvinov.com
-COMMENT= Extract Microsoft Cabinet files from self-extracting installers
+COMMENT= Library to extract CAB files from self-extracting installers
-LIB_DEPENDS= synce.0:${PORTSDIR}/palm/synce-libsynce \
- rapi.2:${PORTSDIR}/palm/synce-librapi2 \
- dynamite.0:${PORTSDIR}/archivers/libdynamite \
- unshield.0:${PORTSDIR}/archivers/unshield
+OPTIONS= LIBSYNCE "Build with libsynce support" on \
+ LIBDYNAMITE "Build with libdynamite support" on \
+ LIBUNSHIELD "Build with libunshield support" on \
+ INNO "Build with expermential Inno Setup support" off \
+ VISE "Build with expermential VISE support" off \
+ MSI "Build with expermential MSI support" off
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
-USE_GNOME= gnometarget
-CONFIGURE_ARGS= --with-libsynce=${LOCALBASE}
+USE_GNOME= gnomehack gnometarget
USE_ICONV= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
-.include <bsd.port.mk>
+MAN1= orange.1
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_LIBSYNCE)
+CONFIGURE_ARGS+= --without-libsynce
+.else
+LIB_DEPENDS+= synce.0:${PORTSDIR}/palm/synce-libsynce
+CONFIGURE_ARGS+= --with-libsynce=${LOCALBASE}
+.endif
+
+.if !defined(WITH_LIBDYNAMITE)
+CONFIGURE_ARGS+= --without-libdynamite
+.else
+LIB_DEPENDS+= dynamite.0:${PORTSDIR}/archivers/libdynamite
+CONFIGURE_ARGS+= --with-libdynamite=${LOCALBASE}
+.endif
+
+.if !defined(WITH_LIBUNSHIELD)
+CONFIGURE_ARGS+= --without-libunshield
+.else
+LIB_DEPENDS+= unshield.0:${PORTSDIR}/archivers/unshield
+CONFIGURE_ARGS+= --with-libunshield=${LOCALBASE}
+.endif
+
+.if defined(WITH_INNO)
+CONFIGURE_ARGS+= --enable-inno
+.endif
+
+.if defined(WITH_VISE)
+CONFIGURE_ARGS+= --enable-vise
+.endif
+
+.if defined(WITH_MSI)
+CONFIGURE_ARGS+= --enable-msi --with-libgsf
+LIB_DEPENDS+= gsf-1.114:${PORTSDIR}/devel/libgsf
+.endif
+
+.include <bsd.port.post.mk>