aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/linux-unace/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-11-14 01:20:43 +0800
committerpav <pav@FreeBSD.org>2005-11-14 01:20:43 +0800
commit1e3f87e533ba3a2762e3b739375e4d3797f611d7 (patch)
tree4a224cca989c02ed8128fb3c1c25c9e4a18ff48b /archivers/linux-unace/Makefile
parent583c6cfc9ecfdfc338b8e60134d5731a15752845 (diff)
downloadfreebsd-ports-gnome-1e3f87e533ba3a2762e3b739375e4d3797f611d7.tar.gz
freebsd-ports-gnome-1e3f87e533ba3a2762e3b739375e4d3797f611d7.tar.zst
freebsd-ports-gnome-1e3f87e533ba3a2762e3b739375e4d3797f611d7.zip
- Rename linux-linunace to linux-unace
Requested by: Andrew P. <infofarmer@gmail.com> (maintainer)
Diffstat (limited to 'archivers/linux-unace/Makefile')
-rw-r--r--archivers/linux-unace/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/archivers/linux-unace/Makefile b/archivers/linux-unace/Makefile
new file mode 100644
index 000000000000..64b32138d024
--- /dev/null
+++ b/archivers/linux-unace/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: linunace
+# Date created: 9 November 2005
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unace
+PORTVERSION= 2.5
+CATEGORIES= archivers linux
+MASTER_SITES= http://www.winace.com/files/
+PKGNAMEPREFIX= linux-
+DISTNAME= lin${PORTNAME}${PORTVERSION:S/.//}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= Extract, view & test ACE archives
+
+NO_PACKAGE= "Distribution is permitted within the original package only"
+
+NO_BUILD= yes
+PLIST_FILES= bin/linunace
+PORTDOCS= licence
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/unace ${PREFIX}/bin/linunace
+ ${BRANDELF} -t Linux ${PREFIX}/bin/linunace
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/licence ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>