aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/lrzip/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-04-12 11:02:36 +0800
committermiwi <miwi@FreeBSD.org>2011-04-12 11:02:36 +0800
commit925c6a46301dc9bebe8a6c4a978c72e83761a600 (patch)
treef16a7ea8aa18a518d0d994d4fbc78a2935d747bf /archivers/lrzip/Makefile
parent077f18c519b1c870934fdd6aea0b1fbc5ce06ff0 (diff)
downloadfreebsd-ports-gnome-925c6a46301dc9bebe8a6c4a978c72e83761a600.tar.gz
freebsd-ports-gnome-925c6a46301dc9bebe8a6c4a978c72e83761a600.tar.zst
freebsd-ports-gnome-925c6a46301dc9bebe8a6c4a978c72e83761a600.zip
This is a compression program optimised for large files. The larger the file
and the more memory you have, the better the compression advantage this will provide, especially once the files are larger than 100MB. The advantage can be chosen to be either size (much smaller than bzip2) or speed (much faster than bzip2). WWW: http://ck.kolivas.org/apps/lrzip/README PR: ports/156267 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'archivers/lrzip/Makefile')
-rw-r--r--archivers/lrzip/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/archivers/lrzip/Makefile b/archivers/lrzip/Makefile
new file mode 100644
index 000000000000..a79b1215dd18
--- /dev/null
+++ b/archivers/lrzip/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: lrzip
+# Date created: 2011-04-08
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lrzip
+PORTVERSION= 0.601
+CATEGORIES= archivers
+MASTER_SITES= http://ck.kolivas.org/apps/lrzip/ \
+ http://files.gslin.org/Software/
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Long Range ZIP or Lzma RZIP
+
+BUILD_DEPENDS= nasm>=0:${PORTSDIR}/devel/nasm
+LIB_DEPENDS= lzo2:${PORTSDIR}/archivers/lzo2
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS+= --enable-asm
+CONFIGURE_ENV+= LDFLAGS=-L${LOCALBASE}/lib
+GNU_CONFIGURE= yes
+LICENSE= GPLv2
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PERL5_BUILD= yes
+
+MAN1= lrunzip.1 \
+ lrzip.1 \
+ lrztar.1 \
+ lrzuntar.1
+MAN5= lrzip.conf.5
+
+.include <bsd.port.mk>