aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/nomarch/Makefile
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-07-14 10:35:50 +0800
committersf <sf@FreeBSD.org>2003-07-14 10:35:50 +0800
commit910bcdc4f4952772370ad56e90b5872a118a07d4 (patch)
tree47e4e75ccb5256b5d785ba92f18afd8447736568 /archivers/nomarch/Makefile
parent31729f665f7ca680cd3c24eaf98e6e7e4b135a47 (diff)
downloadfreebsd-ports-gnome-910bcdc4f4952772370ad56e90b5872a118a07d4.tar.gz
freebsd-ports-gnome-910bcdc4f4952772370ad56e90b5872a118a07d4.tar.zst
freebsd-ports-gnome-910bcdc4f4952772370ad56e90b5872a118a07d4.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead. respect CC, CFLAGS, PREFIX.
Diffstat (limited to 'archivers/nomarch/Makefile')
-rw-r--r--archivers/nomarch/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/archivers/nomarch/Makefile b/archivers/nomarch/Makefile
index 3498e8e04f9e..972f80f5860f 100644
--- a/archivers/nomarch/Makefile
+++ b/archivers/nomarch/Makefile
@@ -8,6 +8,7 @@
PORTNAME= nomarch
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= utils/compress
@@ -15,17 +16,13 @@ MASTER_SITE_SUBDIR= utils/compress
MAINTAINER= ports@FreeBSD.org
COMMENT= Extracts files from the old `.arc' archive format
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
-
+USE_GETOPT_LONG=yes
USE_REINPLACE= yes
+MAKE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
MAN1= nomarch.1
-post-patch:
- @${REINPLACE_CMD} -e "s,^CC,#CC,g ; s,^CFLAGS,#CFLAGS,g ; \
- s,^PREFIX,#PREFIX,g ; \
- s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/nomarch ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/nomarch.1 ${MAN1PREFIX}/man/man1