aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/p5-Archive-Extract/Makefile
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-06-01 01:53:03 +0800
committeraaron <aaron@FreeBSD.org>2006-06-01 01:53:03 +0800
commitb7d8f302a1fb3f884348aaa22b0e3b8d3fb40aaf (patch)
tree52f012dc214c5bc969f476ca45236bba06272555 /archivers/p5-Archive-Extract/Makefile
parent5f643ac51c7eec2a8645b16a2089d3533589af2a (diff)
downloadfreebsd-ports-gnome-b7d8f302a1fb3f884348aaa22b0e3b8d3fb40aaf.tar.gz
freebsd-ports-gnome-b7d8f302a1fb3f884348aaa22b0e3b8d3fb40aaf.tar.zst
freebsd-ports-gnome-b7d8f302a1fb3f884348aaa22b0e3b8d3fb40aaf.zip
Adding port archivers/p5-Archive-Extract, A generic archive extracting mechanism.
Approved by: tobez (implicit)
Diffstat (limited to 'archivers/p5-Archive-Extract/Makefile')
-rw-r--r--archivers/p5-Archive-Extract/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/archivers/p5-Archive-Extract/Makefile b/archivers/p5-Archive-Extract/Makefile
new file mode 100644
index 000000000000..50e449e0f171
--- /dev/null
+++ b/archivers/p5-Archive-Extract/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Archive-Extract
+# Date created: 28 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Archive-Extract
+PORTVERSION= 0.08
+CATEGORIES= archivers perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Archive
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= A generic archive extracting mechanism
+
+BUILD_DEPENDS= ${SITE_PERL}/IPC/Cmd.pm:${PORTSDIR}/devel/p5-IPC-Cmd
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Archive::Extract.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>