aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/p5-IO-Compress-Lzma/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-08-15 16:47:04 +0800
committermiwi <miwi@FreeBSD.org>2010-08-15 16:47:04 +0800
commitf0a2414a49612c133d172fc1bba1eb5f05a9bc72 (patch)
treefa66dee40b23380e9e5213f04d7d84d77239e0ea /archivers/p5-IO-Compress-Lzma/Makefile
parente43d466caa740440ca15eb8f66fe92b6ee4f63f6 (diff)
downloadfreebsd-ports-gnome-f0a2414a49612c133d172fc1bba1eb5f05a9bc72.tar.gz
freebsd-ports-gnome-f0a2414a49612c133d172fc1bba1eb5f05a9bc72.tar.zst
freebsd-ports-gnome-f0a2414a49612c133d172fc1bba1eb5f05a9bc72.zip
IO::Compress::Lzma is a perl module for reading/writing lzma files/buffer.
WWW: http://search.cpan.org/dist/IO-Compress-Lzma/ PR: ports/148981 Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet at sunpoet.net>
Diffstat (limited to 'archivers/p5-IO-Compress-Lzma/Makefile')
-rw-r--r--archivers/p5-IO-Compress-Lzma/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/archivers/p5-IO-Compress-Lzma/Makefile b/archivers/p5-IO-Compress-Lzma/Makefile
new file mode 100644
index 000000000000..622e5c3bcf40
--- /dev/null
+++ b/archivers/p5-IO-Compress-Lzma/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-IO-Compress-Lzma
+# Date created: 2010-07-26
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Compress-Lzma
+PORTVERSION= 2.030
+CATEGORIES= archivers perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@sunpoet.net
+COMMENT= Write lzma files/buffers
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Compress/Raw/Lzma.pm:${PORTSDIR}/archivers/p5-Compress-Raw-Lzma \
+ ${SITE_PERL}/IO/Compress/Base.pm:${PORTSDIR}/archivers/p5-IO-Compress-Base
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Compress/Raw/Lzma.pm:${PORTSDIR}/archivers/p5-Compress-Raw-Lzma \
+ ${SITE_PERL}/IO/Compress/Base.pm:${PORTSDIR}/archivers/p5-IO-Compress-Base
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::Compress::Lzma.3 IO::Compress::Xz.3 \
+ IO::Uncompress::UnLzma.3 IO::Uncompress::UnXz.3
+
+.include <bsd.port.mk>
r0.10-removal&id=6a2a890c5cd397f9f0287409c2aa0244d50f3573'>Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for thiskwm2010-05-1136-3641/+1060 * Begin the process of deprecating sysutils/rc_subr bydougb2010-03-271-1/+1 * Fix the environment variables when probing USB2 interfaces as their propertymarcus2010-01-242-5/+5 * Correct the properties for USB interface devices.marcus2010-01-242-4/+4 * Presenting GNOME 2.28.1 for FreeBSD. The official release notes for thismarcus2009-11-2919-463/+667 * Add support to create users and groups from information stored in UIDs/GIDsflz2009-09-072-28/+4 * -Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.mezz2009-08-031-1/+1 * Fix a few "bad example" problems in the rc.d scripts that have beendougb2009-07-161-2/+1 * Fix the build on recent -CURRENT with the removal of oldusb.marcus2009-05-304-39/+145 * Optimize the check for an existing GEOM object and correct a nearby memorymarcus2009-05-242-16/+27 * * Correct a potential infinite recursion loop triggered by the new GEOMmarcus2009-05-245-27/+33 * Add some more argument sanity checking to the fuse helper script. Thismarcus2009-04-102-5/+29 * One more fix for hal and PolicyKit. Apparently haldaemon requiresmarcus2009-03-313-1/+8 * Fix hal on the latest -CURRENT now that libusb20 has been renamed.marcus2009-03-147-59/+167 * Fix build: 80064 -> 800064kevlo2009-03-051-1/+1 * Set the device node to NULL for usb keyboards. The xorg keyboardrnoland2009-03-033-10/+19 * Add the new usb2 probers to the plist.marcus2009-03-032-1/+9 * Chase the recent usb2 changes in HEAD.marcus2009-02-281-6/+10 * Fix build on older versions of FreeBSD.marcus2009-02-261-22/+21 * Actually commit the build for the old USB backend.marcus2009-02-251-6/+25 * Fix the build now that usb2 has been renamed.marcus2009-02-243-10/+24 * Fix probe-hiddev building on very recent -CURRENT.marcus2009-02-241-0/+33 * * Add support for usb2 in -CURRENT.marcus2009-02-2420-54/+1633 * Check to see if "/dev/usb " exists, and if it does, don't try tomarcus2009-02-161-3/+31 * - Do not allow openning /dev/sysmouse multiple times. When there arejkim2009-02-053-19/+80 * Fix breakages introduced in the previous commit. hf_has_sysctl() is onlyjkim2009-02-031-6/+15 * - Do not search for Linux-specific hald-addon-acpi module.jkim2009-02-034-5/+73 * Quiet the syslog messages from hal.marcus2009-02-012-1/+26 * Take another stab at fixing mouse support in X. This approach eliminatesmarcus2009-01-279-24/+556 * When changing the input.device property we need to remove the propertyrnoland2009-01-243-26/+9 * - Update X.org ports to 7.4+ (few ports are more recent than the katamari).flz2009-01-242-5/+11 * Add two additional properties to disc media so that applications canmarcus2009-01-162-1/+40 * Presenting GNOME 2.24 for FreeBSD.marcus2009-01-1012-44/+659