aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/p5-IO-Compress-Zlib/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2006-12-03 19:39:43 +0800
committerdemon <demon@FreeBSD.org>2006-12-03 19:39:43 +0800
commit1c99b277b596e74b74589cc4e8b66acbe4a51820 (patch)
treeafee0804cda573cbba8033c0a3b54ae7397f88cc /archivers/p5-IO-Compress-Zlib/Makefile
parent2ca01e30c783c6885ec021287ca63164076752bf (diff)
downloadfreebsd-ports-gnome-1c99b277b596e74b74589cc4e8b66acbe4a51820.tar.gz
freebsd-ports-gnome-1c99b277b596e74b74589cc4e8b66acbe4a51820.tar.zst
freebsd-ports-gnome-1c99b277b596e74b74589cc4e8b66acbe4a51820.zip
New port: p5-IO=Compress-Zlib.
A Perl5 interface to allow reading and writing of RFC 1950, 1951, 1952 (i.e. gzip) and zip files/buffers.
Diffstat (limited to 'archivers/p5-IO-Compress-Zlib/Makefile')
-rw-r--r--archivers/p5-IO-Compress-Zlib/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/archivers/p5-IO-Compress-Zlib/Makefile b/archivers/p5-IO-Compress-Zlib/Makefile
new file mode 100644
index 000000000000..04eceacfc7ac
--- /dev/null
+++ b/archivers/p5-IO-Compress-Zlib/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-IO-Compress-Zlib
+# Date created: 3 December 2006
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Compress-Zlib
+PORTVERSION= 2.001
+CATEGORIES= archivers perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Perl5 interface for reading and writing of (g)zip files
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Compress/Raw/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib \
+ ${SITE_PERL}/IO/Compress/Base.pm:${PORTSDIR}/archivers/p5-IO-Compress-Base
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= IO::Uncompress::RawInflate.3 IO::Uncompress::Unzip.3 \
+ IO::Uncompress::Inflate.3 IO::Compress::Deflate.3 \
+ IO::Compress::Zip.3 IO::Uncompress::Gunzip.3 \
+ IO::Compress::RawDeflate.3 IO::Uncompress::AnyInflate.3 \
+ IO::Compress::Gzip.3
+
+.include <bsd.port.mk>