aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/pbzip2/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-12-07 10:31:16 +0800
committerijliao <ijliao@FreeBSD.org>2004-12-07 10:31:16 +0800
commit25eba2814612e1f2f58e30635d58847d597e2b07 (patch)
tree1ecc2529b2c990b487e2d26852fdf73245918b31 /archivers/pbzip2/Makefile
parent80d55dc3282e6471cfeeeb63bb7cef498873a67d (diff)
downloadfreebsd-ports-gnome-25eba2814612e1f2f58e30635d58847d597e2b07.tar.gz
freebsd-ports-gnome-25eba2814612e1f2f58e30635d58847d597e2b07.tar.zst
freebsd-ports-gnome-25eba2814612e1f2f58e30635d58847d597e2b07.zip
add pbzip2 0.8.2
Parallel BZIP2
Diffstat (limited to 'archivers/pbzip2/Makefile')
-rw-r--r--archivers/pbzip2/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/archivers/pbzip2/Makefile b/archivers/pbzip2/Makefile
new file mode 100644
index 000000000000..9dbf051648be
--- /dev/null
+++ b/archivers/pbzip2/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: pbzip2
+# Date created: Dec 7, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= pbzip2
+PORTVERSION= 0.8.2
+CATEGORIES= archivers
+MASTER_SITES= http://compression.ca/pbzip2/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Parallel BZIP2
+
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/pbzip2
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,-pthread -lpthread,${PTHREAD_LIBS},g" \
+ -e "s,-O3,${CXXFLAGS}," \
+ -e "s,^CC,#CC," \
+ -e "s,CC,CXX," ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>