aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/pecl-phar
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-08-21 17:10:15 +0800
committermiwi <miwi@FreeBSD.org>2007-08-21 17:10:15 +0800
commit515ecef50071658629370b13314b594cd0e54823 (patch)
treecd727f6e9b4e554f8bdf5bc253e7a9e27eb86e4d /archivers/pecl-phar
parent150549fbd1c1a6063e6bac132735d6852e92d34e (diff)
downloadfreebsd-ports-gnome-515ecef50071658629370b13314b594cd0e54823.tar.gz
freebsd-ports-gnome-515ecef50071658629370b13314b594cd0e54823.tar.zst
freebsd-ports-gnome-515ecef50071658629370b13314b594cd0e54823.zip
The phar extension provides the phar stream wrapper and the Phar
class for manipulating self-contained PHP Archive (phar) files. The Phar class can be used to create and to extract contents of phar files as well as iterating over their contents. PHP Archive files (Phars) are special collections of files that can be transparently run right out of the file, similar to Java's jar archive files. Using a phar archive, it is possible to distribute a complete PHP application in a single file that will run out of the file without modification or extraction. WWW: http://pecl.php.net/package/phar/ PR: ports/115224 Submitted by: Ditesh Shashikant Gathani <ditesh at gathani.org>
Diffstat (limited to 'archivers/pecl-phar')
-rw-r--r--archivers/pecl-phar/Makefile38
-rw-r--r--archivers/pecl-phar/distinfo3
-rw-r--r--archivers/pecl-phar/pkg-descr13
3 files changed, 54 insertions, 0 deletions
diff --git a/archivers/pecl-phar/Makefile b/archivers/pecl-phar/Makefile
new file mode 100644
index 000000000000..bcd6f4180508
--- /dev/null
+++ b/archivers/pecl-phar/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: pecl-phar
+# Date created: 6 Aug 2007
+# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phar
+PORTVERSION= 1.2.0
+CATEGORIES= archivers pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= ditesh@gathani.org
+COMMENT= A PECL extension which allows running applications out of .phar files
+
+USE_PHP= hash spl
+USE_PHP_BUILD= yes
+USE_PHPEXT= yes
+
+OPTIONS= BZ2 "Enable bz2 compression support" off \
+ ZLIB "Enable gzip compression support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_BZ2) && !defined(WITHOUT_BZ2)
+USE_PHP+= bz2
+.endif
+
+.if defined(WITH_ZLIB) && !defined(WITHOUT_ZLIB)
+USE_PHP+= zlib
+.endif
+
+CONFIGURE_ARGS= --enable-phar
+
+.include <bsd.port.post.mk>
diff --git a/archivers/pecl-phar/distinfo b/archivers/pecl-phar/distinfo
new file mode 100644
index 000000000000..525c0fd10f79
--- /dev/null
+++ b/archivers/pecl-phar/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/phar-1.2.0.tgz) = bafae732137b0b8977e289910a36f438
+SHA256 (PECL/phar-1.2.0.tgz) = 83fad1a7946e8355aebf40e4928a2a6323c86f16df41ad9f67fa3b3852229fc8
+SIZE (PECL/phar-1.2.0.tgz) = 67432
diff --git a/archivers/pecl-phar/pkg-descr b/archivers/pecl-phar/pkg-descr
new file mode 100644
index 000000000000..0c56d0cdd71b
--- /dev/null
+++ b/archivers/pecl-phar/pkg-descr
@@ -0,0 +1,13 @@
+The phar extension provides the phar stream wrapper and the Phar
+class for manipulating self-contained PHP Archive (phar) files.
+The Phar class can be used to create and to extract contents of
+phar files as well as iterating over their contents.
+
+PHP Archive files (Phars) are special collections of files that
+can be transparently run right out of the file, similar to Java's
+jar archive files. Using a phar archive, it is possible to distribute
+a complete PHP application in a single file that will run out of the
+file without modification or extraction.
+
+WWW: http://pecl.php.net/package/phar/
+