aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/php71-zlib
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2017-01-24 19:54:20 +0800
committertz <tz@FreeBSD.org>2017-01-24 19:54:20 +0800
commit6848976140b7b23bae6554e8e69c63d54ff6ef33 (patch)
treead7f282ff1e254cc6c54bfc24d23efee0af4d12e /archivers/php71-zlib
parent8890d0606a504e6c6016614e5077c8d36dc54d8c (diff)
downloadfreebsd-ports-gnome-6848976140b7b23bae6554e8e69c63d54ff6ef33.tar.gz
freebsd-ports-gnome-6848976140b7b23bae6554e8e69c63d54ff6ef33.tar.zst
freebsd-ports-gnome-6848976140b7b23bae6554e8e69c63d54ff6ef33.zip
Add PHP 7.1
Thanks to: mat, pi, ale, martin@waschbuesch.de and franco@opnsense.org
Diffstat (limited to 'archivers/php71-zlib')
-rw-r--r--archivers/php71-zlib/Makefile9
-rw-r--r--archivers/php71-zlib/files/patch-zlib.c10
2 files changed, 19 insertions, 0 deletions
diff --git a/archivers/php71-zlib/Makefile b/archivers/php71-zlib/Makefile
new file mode 100644
index 000000000000..24e808153df0
--- /dev/null
+++ b/archivers/php71-zlib/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -zlib
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php71-zlib/files/patch-zlib.c b/archivers/php71-zlib/files/patch-zlib.c
new file mode 100644
index 000000000000..be02c50d1df6
--- /dev/null
+++ b/archivers/php71-zlib/files/patch-zlib.c
@@ -0,0 +1,10 @@
+--- zlib.c.orig 2016-06-21 19:57:08 UTC
++++ zlib.c
+@@ -1480,6 +1480,7 @@ static PHP_MSHUTDOWN_FUNCTION(zlib)
+ /* {{{ PHP_RINIT_FUNCTION */
+ static PHP_RINIT_FUNCTION(zlib)
+ {
++ ZLIBG(output_compression) = 0;
+ ZLIBG(compression_coding) = 0;
+ if (!ZLIBG(handler_registered)) {
+ ZLIBG(output_compression) = ZLIBG(output_compression_default);