aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/php72-phar
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2017-11-16 18:48:48 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:57:22 +0800
commit5b27cbc62c5d8f59985081907ae7a2d906418f1c (patch)
treefb9f954553ab0d387d2ed80421e3a595dbe1e0cc /archivers/php72-phar
parente7c9b3f082da3e8d0d0fefb08950ae1d9606aebb (diff)
downloadfreebsd-ports-gnome-5b27cbc62c5d8f59985081907ae7a2d906418f1c.tar.gz
freebsd-ports-gnome-5b27cbc62c5d8f59985081907ae7a2d906418f1c.tar.zst
freebsd-ports-gnome-5b27cbc62c5d8f59985081907ae7a2d906418f1c.zip
Add PHP 7.2 RC6
Notable changes: - mcrypt module was removed - sodium module was added - sybase_ct artifacts removed Also many PECL ports will not work with this version since some files got renamed. Reviewed by: mat, ale, Rainer Duffner <rainer@ultra-secure.de> Differential Revision: https://reviews.freebsd.org/D12980
Diffstat (limited to 'archivers/php72-phar')
-rw-r--r--archivers/php72-phar/Makefile9
-rw-r--r--archivers/php72-phar/files/patch-config.m441
-rw-r--r--archivers/php72-phar/files/patch-phar.c11
3 files changed, 61 insertions, 0 deletions
diff --git a/archivers/php72-phar/Makefile b/archivers/php72-phar/Makefile
new file mode 100644
index 000000000000..8adfdb8f76aa
--- /dev/null
+++ b/archivers/php72-phar/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php72
+
+PKGNAMESUFFIX= -phar
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php72-phar/files/patch-config.m4 b/archivers/php72-phar/files/patch-config.m4
new file mode 100644
index 000000000000..1aba3bd9a5a8
--- /dev/null
+++ b/archivers/php72-phar/files/patch-config.m4
@@ -0,0 +1,41 @@
+--- config.m4.orig 2016-06-21 19:56:50 UTC
++++ config.m4
+@@ -4,8 +4,38 @@ dnl config.m4 for extension phar
+ PHP_ARG_ENABLE(phar, for phar archive support,
+ [ --disable-phar Disable phar support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir PHAR: pcre install prefix], no, no)
++
++
+ if test "$PHP_PHAR" != "no"; then
++
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ PHP_NEW_EXTENSION(phar, util.c tar.c zip.c stream.c func_interceptors.c dirstream.c phar.c phar_object.c phar_path_check.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
++ PHP_HASH=yes
+ AC_MSG_CHECKING([for phar openssl support])
+ if test "$PHP_HASH_SHARED" != "yes"; then
+ if test "$PHP_HASH" != "no"; then
diff --git a/archivers/php72-phar/files/patch-phar.c b/archivers/php72-phar/files/patch-phar.c
new file mode 100644
index 000000000000..e7ae6cb3328d
--- /dev/null
+++ b/archivers/php72-phar/files/patch-phar.c
@@ -0,0 +1,11 @@
+--- phar.c.orig 2016-06-21 19:56:49 UTC
++++ phar.c
+@@ -3589,7 +3589,7 @@ static const zend_module_dep phar_deps[]
+ ZEND_MOD_OPTIONAL("openssl")
+ ZEND_MOD_OPTIONAL("zlib")
+ ZEND_MOD_OPTIONAL("standard")
+-#if defined(HAVE_HASH) && !defined(COMPILE_DL_HASH)
++#if defined(HAVE_HASH)
+ ZEND_MOD_REQUIRED("hash")
+ #endif
+ #if HAVE_SPL