aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/rpm4
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2004-03-10 03:40:38 +0800
committerglewis <glewis@FreeBSD.org>2004-03-10 03:40:38 +0800
commit0bf4cb87335558d7d6c7a77212d01366ca69ca07 (patch)
tree0e2378ca662b28f26696443373fa004773767927 /archivers/rpm4
parent95eb198a6e2dcd866c4a84a028a1c37be2fb5ef4 (diff)
downloadfreebsd-ports-gnome-0bf4cb87335558d7d6c7a77212d01366ca69ca07.tar.gz
freebsd-ports-gnome-0bf4cb87335558d7d6c7a77212d01366ca69ca07.tar.zst
freebsd-ports-gnome-0bf4cb87335558d7d6c7a77212d01366ca69ca07.zip
. Build and install API documentation if NOPORTDOCS isn't set.
. Bump PORTREVISION for this change.
Diffstat (limited to 'archivers/rpm4')
-rw-r--r--archivers/rpm4/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index 84a1b6b3d069..64049577ac83 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -6,6 +6,7 @@
PORTNAME= rpm
PORTVERSION= 4.0.4
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/ \
ftp://ftp.mirror.ac.uk/sites/ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/
@@ -20,6 +21,9 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/gsed:${PORTSDIR}/textproc/gsed
.if !exists(/usr/bin/bzip2)
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
.endif
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
+.endif
USE_LIBTOOL_VER=14
USE_GMAKE= yes
@@ -51,11 +55,23 @@ CONFIGURE_ARGS+=--without-db \
MAN1= gendiff.1
MAN8= rpm.8 rpm2cpio.8 rpmbuild.8
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's:%%LOCALBASE%%:${LOCALBASE}:' \
${WRKSRC}/configure ${WRKSRC}/beecrypt/configure
post-install:
+.if !defined(NOPORTDOCS)
+ # Install documentation
+ ${MKDIR} ${DOCSDIR}/apidocs/html
+ cd ${WRKSRC}/apidocs/html && ${FIND} . \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} \
+ ${DOCSDIR}/apidocs/html/
+.endif
+ # Run package installation script
${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>