aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/rpm5/Makefile
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2004-03-05 10:26:10 +0800
committerglewis <glewis@FreeBSD.org>2004-03-05 10:26:10 +0800
commit48d734ba2811eed6401b18cf61f9545a12cec7e1 (patch)
treec4960ac5bea5fb480d2855674417914c6c1e480b /archivers/rpm5/Makefile
parentc44b3e416117c2a0d669b1777186611c4b4b86e8 (diff)
downloadfreebsd-ports-gnome-48d734ba2811eed6401b18cf61f9545a12cec7e1.tar.gz
freebsd-ports-gnome-48d734ba2811eed6401b18cf61f9545a12cec7e1.tar.zst
freebsd-ports-gnome-48d734ba2811eed6401b18cf61f9545a12cec7e1.zip
Add a port of rpm 4.0.4:
"The Red Hat Package Manager (RPM) is a powerful command line driven package management system capable of installing, uninstalling, verifying, querying, and updating computer software packages. Each software package consists of an archive of files along with information about the package like its version, a description, and the like. There is also a related API ("Application Program Interface"), permitting advanced developers to bypass 'shelling out' to a command line, and to manage such transactions from within a native coding language. WWW: http://www.rpm.org/" 4.0.4 was chosen because: . The only newer version available as a tarball (4.1) is buggy. . This version closely corresponds to our current default linux_base. . This version uses the version of popt we have in the tree (unfortunately it uses an earlier version of beecrypt). . This version is a lot less work to port than 4.2 (elfutils). However, I am considering how best this port could be updated to a more recent version (e.g. 4.1.1 or 4.2, probably the latter). This wasn't an update to the current rpm port as I haven't done enough testing of other ports that use rpm with it. Tested on 4.9/i386, 5.2/sparc64 and 5.2/alpha.
Diffstat (limited to 'archivers/rpm5/Makefile')
-rw-r--r--archivers/rpm5/Makefile61
1 files changed, 61 insertions, 0 deletions
diff --git a/archivers/rpm5/Makefile b/archivers/rpm5/Makefile
new file mode 100644
index 000000000000..2c6ca5877949
--- /dev/null
+++ b/archivers/rpm5/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: rpm
+# Date created: 6 May 2003
+# Whom: Greg Lewis <glewis@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= rpm
+PORTVERSION= 4.0.4
+CATEGORIES= archivers
+MASTER_SITES= ftp://ftp.rpm.org/pub/rpm/dist/ \
+ ftp://ftp.mirror.ac.uk/sites/ftp.rpm.org/pub/rpm/dist/
+MASTER_SITE_SUBDIR= rpm-4.0.x
+
+MAINTAINER= glewis@FreeBSD.org
+COMMENT= The RPM Package Manager
+
+LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3 \
+ iconv.3:${PORTSDIR}/converters/libiconv \
+ popt.0:${PORTSDIR}/devel/popt
+BUILD_DEPENDS= ${LOCALBASE}/bin/gsed:${PORTSDIR}/textproc/gsed
+.if !exists(/usr/bin/bzip2)
+LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
+
+USE_LIBTOOL_VER=14
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_REINPLACE= yes
+LATEST_LINK= rpm4
+CONFLICTS= beecrypt-* rpm-3.* rpm2cpio-*
+
+.if defined(WITH_PYTHON)
+CONFIGURE_ARGS+=--with-python=auto
+USE_PYTHON= yes
+PLIST_SUB+= PYTHON=""
+CPPFLAGS+= -I${PYTHON_INCLUDEDIR}
+LDFLAGS+= -L${PYTHON_LIBDIR}
+.else
+CONFIGURE_ARGS+=--without-python
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS+=--without-db
+CONFIGURE_ARGS+=--with-popt-prefix="${LOCALBASE}"
+CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc
+
+MAN1= gendiff.1
+MAN8= rpm.8 rpm2cpio.8 rpmbuild.8
+
+post-patch:
+ ${REINPLACE_CMD} -e 's:%%LOCALBASE%%:${LOCALBASE}:' \
+ ${WRKSRC}/configure ${WRKSRC}/beecrypt/configure
+
+post-install:
+ ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>