aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/szip/Makefile
diff options
context:
space:
mode:
authormarkp <markp@FreeBSD.org>2002-02-17 15:58:57 +0800
committermarkp <markp@FreeBSD.org>2002-02-17 15:58:57 +0800
commitb6ff1916229df813f7653976fa3a43d499863b7b (patch)
tree06510c16af03b21215c41a7263882e446f705802 /archivers/szip/Makefile
parentf7b3d1cc4c609b18684dc447cea7fd2a8cb10c25 (diff)
downloadfreebsd-ports-gnome-b6ff1916229df813f7653976fa3a43d499863b7b.tar.gz
freebsd-ports-gnome-b6ff1916229df813f7653976fa3a43d499863b7b.tar.zst
freebsd-ports-gnome-b6ff1916229df813f7653976fa3a43d499863b7b.zip
Add szip 1.12b, a fast compression utility.
PR: 33934 Submitted by: Igor Pokrovsky <tiamat@telegraph.spb.ru>
Diffstat (limited to 'archivers/szip/Makefile')
-rw-r--r--archivers/szip/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/archivers/szip/Makefile b/archivers/szip/Makefile
new file mode 100644
index 000000000000..abb9d214de02
--- /dev/null
+++ b/archivers/szip/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: szip
+# Date created: 15 January 2002
+# Whom: Igor Pokrovsky <tiamat@telegraph.spb.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= szip
+PORTVERSION= 1.12b
+CATEGORIES= archivers
+MASTER_SITES= http://www.compressconsult.com/szip/
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/.//}_FreeBSD
+
+MAINTAINER= tiamat@telegraph.spb.ru
+
+NO_BUILD= yes
+ONLY_FOR_ARCHS= i386
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/*.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>