aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/xz
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2011-03-01 00:43:27 +0800
committernaddy <naddy@FreeBSD.org>2011-03-01 00:43:27 +0800
commit8832e625e58c4d40a790a133d95af09a4fde28a9 (patch)
treeb72578012e20cefc019a17ce04ac880ab2dba8c3 /archivers/xz
parent1b1eee15e5eb4e2887e4d8088ef7937602341e56 (diff)
downloadfreebsd-ports-gnome-8832e625e58c4d40a790a133d95af09a4fde28a9.tar.gz
freebsd-ports-gnome-8832e625e58c4d40a790a133d95af09a4fde28a9.tar.zst
freebsd-ports-gnome-8832e625e58c4d40a790a133d95af09a4fde28a9.zip
Update to 5.0.1. User-visible changes:
* xz --force now (de)compresses files that have setuid, setgid, or sticky bit set and files that have multiple hard links. The man page had it documented this way already, but the code had a bug. * gzip and bzip2 support in xzdiff was fixed.
Diffstat (limited to 'archivers/xz')
-rw-r--r--archivers/xz/Makefile12
-rw-r--r--archivers/xz/distinfo4
-rw-r--r--archivers/xz/files/patch-Makefile.in8
3 files changed, 14 insertions, 10 deletions
diff --git a/archivers/xz/Makefile b/archivers/xz/Makefile
index 516a7377ea24..8172b97f28b6 100644
--- a/archivers/xz/Makefile
+++ b/archivers/xz/Makefile
@@ -6,9 +6,11 @@
#
PORTNAME= xz
-PORTVERSION= 5.0.0
+PORTVERSION= 5.0.1
CATEGORIES= archivers
-MASTER_SITES= http://tukaani.org/xz/
+#MASTER_SITES= http://tukaani.org/xz/
+# tukaani.org doesn't interop with fetch(1) as of 2011-02-28
+MASTER_SITES= ${MASTER_SITE_NETBSD}
MAINTAINER= naddy@FreeBSD.org
COMMENT= LZMA compression and decompression tools
@@ -16,6 +18,7 @@ COMMENT= LZMA compression and decompression tools
CONFLICTS= lzma-[0-9]* lzmautils-[0-9]* lzmalib-[0-9]*
MAKE_JOBS_SAFE= yes
+USE_BZIP2= yes
USE_LDCONFIG= yes
USE_GNOME= gnomehack
GNU_CONFIGURE= yes
@@ -28,7 +31,7 @@ CONFIGURE_ARGS= --disable-nls
CONFIGURE_TARGET= ${ARCH:S/amd64/x86_64/}-portbld-freebsd${OSREL}
.if !defined(NOPORTDOCS)
-INSTALL_TARGET= install install-dist_docDATA
+INSTALL_TARGET= install install-dist_docDATA install-dist_examplesDATA
.endif
MAN1= lzmainfo.1 xz.1 xzdec.1 xzdiff.1 xzgrep.1 xzless.1 xzmore.1
@@ -43,7 +46,8 @@ MLINKS= xz.1 lzcat.1 xzdiff.1 lzcmp.1 \
xzgrep.1 xzegrep.1 xzgrep.1 xzfgrep.1
PORTDOCS= AUTHORS COPYING COPYING.GPLv2 NEWS README THANKS TODO \
- faq.txt history.txt lzma-file-format.txt xz-file-format.txt
+ faq.txt history.txt lzma-file-format.txt xz-file-format.txt \
+ examples
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
diff --git a/archivers/xz/distinfo b/archivers/xz/distinfo
index 132a6613e368..928a638de911 100644
--- a/archivers/xz/distinfo
+++ b/archivers/xz/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xz-5.0.0.tar.gz) = eba9211990a642fc2c35ea02618b710c7fa898d78ccca48b546a07bdde03c44d
-SIZE (xz-5.0.0.tar.gz) = 1232154
+SHA256 (xz-5.0.1.tar.bz2) = 9b380f502d37085a60821484a3a13747454638927cc36033be64970512451ed8
+SIZE (xz-5.0.1.tar.bz2) = 1005959
diff --git a/archivers/xz/files/patch-Makefile.in b/archivers/xz/files/patch-Makefile.in
index bac0bf9cd09f..f8e1d58bd807 100644
--- a/archivers/xz/files/patch-Makefile.in
+++ b/archivers/xz/files/patch-Makefile.in
@@ -1,10 +1,10 @@
---- Makefile.in.orig 2009-09-16 19:57:05.000000000 +0200
-+++ Makefile.in 2009-09-16 19:59:02.000000000 +0200
-@@ -785,7 +785,7 @@ info: info-recursive
+--- Makefile.in.orig 2011-02-28 17:22:23.000000000 +0100
++++ Makefile.in 2011-02-28 17:23:10.000000000 +0100
+@@ -814,7 +814,7 @@ info: info-recursive
info-am:
--install-data-am: install-dist_docDATA
+-install-data-am: install-dist_docDATA install-dist_examplesDATA
+install-data-am:
install-dvi: install-dvi-recursive