aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-10-23 05:13:49 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-10-23 05:13:49 +0800
commit0ede3aaa7bb9ddc7c460071f3cc81e9f9fd75384 (patch)
tree03221ac5201ecaf21c39c3efaa17988800d2a2c0 /archivers
parentdd79e235fffc225c59be46fec8b5ffe5c21281d3 (diff)
downloadfreebsd-ports-gnome-0ede3aaa7bb9ddc7c460071f3cc81e9f9fd75384.tar.gz
freebsd-ports-gnome-0ede3aaa7bb9ddc7c460071f3cc81e9f9fd75384.tar.zst
freebsd-ports-gnome-0ede3aaa7bb9ddc7c460071f3cc81e9f9fd75384.zip
Support staging
Diffstat (limited to 'archivers')
-rw-r--r--archivers/tardy/Makefile9
-rw-r--r--archivers/unlzx/Makefile3
-rw-r--r--archivers/unmass/Makefile3
-rw-r--r--archivers/unzoo/Makefile9
4 files changed, 10 insertions, 14 deletions
diff --git a/archivers/tardy/Makefile b/archivers/tardy/Makefile
index 6c8b332dfe8e..555a7e6b2f01 100644
--- a/archivers/tardy/Makefile
+++ b/archivers/tardy/Makefile
@@ -17,7 +17,6 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost
${LOCALBASE}/include/libiberty/libiberty.h:${PORTSDIR}/devel/gnulibiberty
LIB_DEPENDS= explain:${PORTSDIR}/devel/libexplain
-NO_STAGE= yes
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
@@ -25,8 +24,7 @@ MAKE_JOBS_UNSAFE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= tardy.1
-PLIST_FILES= bin/tardy
+PLIST_FILES= bin/tardy man/man1/tardy.1.gz
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -44,7 +42,8 @@ post-patch:
.endfor
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/man/man1/${MAN1} ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/man1/${PORTNAME}.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.post.mk>
diff --git a/archivers/unlzx/Makefile b/archivers/unlzx/Makefile
index 5c15e80a0785..2705eee3ae39 100644
--- a/archivers/unlzx/Makefile
+++ b/archivers/unlzx/Makefile
@@ -11,7 +11,6 @@ EXTRACT_SUFX= .gz
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Extracts .lzx archives from Amiga systems
-NO_STAGE= yes
PLIST_FILES= bin/unlzx
do-extract:
@@ -22,6 +21,6 @@ do-build:
${CC} ${CFLAGS} -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/archivers/unmass/Makefile b/archivers/unmass/Makefile
index 52f5bd758280..112795fc1d8b 100644
--- a/archivers/unmass/Makefile
+++ b/archivers/unmass/Makefile
@@ -12,7 +12,6 @@ COMMENT= Extract game archives such as wad, dar, mea exe's, and many more
LICENSE= GPLv2
-NO_STAGE= yes
USES= gmake
GNU_CONFIGURE= yes
USE_DOS2UNIX= yes
@@ -28,6 +27,6 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME}_kdev \
- ${PREFIX}/bin/${PORTNAME}
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>
diff --git a/archivers/unzoo/Makefile b/archivers/unzoo/Makefile
index 412b2a40f7a9..65f3dcf33893 100644
--- a/archivers/unzoo/Makefile
+++ b/archivers/unzoo/Makefile
@@ -17,9 +17,7 @@ COMMENT= ZOO archive extractor
EXTRA_DEFINES= -DSYS_IS_UNIX -DSYS_HAS_MKDIR
-NO_STAGE= yes
-MAN1= unzoo.1
-PLIST_FILES= bin/unzoo
+PLIST_FILES= bin/unzoo man/man1/unzoo.1.gz
CFLAGS+= -trigraphs
@@ -32,7 +30,8 @@ do-build:
${WRKSRC}/${PORTNAME}.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/debian/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/debian/${PORTNAME}.1 \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>