aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2000-01-23 10:40:23 +0800
committerkris <kris@FreeBSD.org>2000-01-23 10:40:23 +0800
commit1749d7996339f1e5cb99fc0f5b5aada74202b608 (patch)
treeca647b0de75b0782418f26574a5dec856dff5b6f /archivers
parent8d6fa4c154a64ecafcf1ac58ee0604d9b46dd687 (diff)
downloadfreebsd-ports-gnome-1749d7996339f1e5cb99fc0f5b5aada74202b608.tar.gz
freebsd-ports-gnome-1749d7996339f1e5cb99fc0f5b5aada74202b608.tar.zst
freebsd-ports-gnome-1749d7996339f1e5cb99fc0f5b5aada74202b608.zip
Respect CC
Diffstat (limited to 'archivers')
-rw-r--r--archivers/unzip/files/patch-aa20
1 files changed, 20 insertions, 0 deletions
diff --git a/archivers/unzip/files/patch-aa b/archivers/unzip/files/patch-aa
new file mode 100644
index 000000000000..297d25954672
--- /dev/null
+++ b/archivers/unzip/files/patch-aa
@@ -0,0 +1,20 @@
+--- unix/Makefile.orig Thu Nov 19 13:59:08 1998
++++ unix/Makefile Sat Jan 22 17:23:42 2000
+@@ -42,7 +42,7 @@
+ # such as -DDOSWILD).
+
+ # UnZip flags
+-CC = cc# try using "gcc" target rather than changing this (CC and LD
++CC ?= cc# try using "gcc" target rather than changing this (CC and LD
+ LD = $(CC)# must match, else "unresolved symbol: ___main" is possible)
+ AS = as
+ LOC = $(LOCAL_UNZIP)
+@@ -680,7 +680,7 @@
+ # FreeBSD on Intel:
+ freebsd: unix_make
+ @echo 'NOTE: use bsd target for non-Intel FreeBSD compiles (if any).'
+- $(MAKE) unzips CC=gcc LD=gcc AS=gcc\
++ $(MAKE) unzips CC=$(CC) LD=$(CC) AS=$(CC)\
+ CF="-O3 -Wall -I. -DASM_CRC -DBSD $(LOC)"\
+ AF="-Di386 $(AF)" CRC32=crc_gcc
+