aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2009-06-08 01:24:26 +0800
committerdhn <dhn@FreeBSD.org>2009-06-08 01:24:26 +0800
commit729fee5a40b00f213a4c2fab4e138d938d0c2010 (patch)
tree44878c2427a2dec17fec4e630ac379ee5a1a4768 /archivers
parent6cc3b3b1a0631c65770912ab4aa980b5efea9c31 (diff)
downloadfreebsd-ports-gnome-729fee5a40b00f213a4c2fab4e138d938d0c2010.tar.gz
freebsd-ports-gnome-729fee5a40b00f213a4c2fab4e138d938d0c2010.tar.zst
freebsd-ports-gnome-729fee5a40b00f213a4c2fab4e138d938d0c2010.zip
- Fix build with custom LOCALBASE.
- Fix iconv dependency PR: ports/135326 Submitted by: Yar Odin <yarodin@gmail.com> (maintainer)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/unrar-iconv/Makefile3
-rw-r--r--archivers/unrar-iconv/files/patch-iconv9
2 files changed, 8 insertions, 4 deletions
diff --git a/archivers/unrar-iconv/Makefile b/archivers/unrar-iconv/Makefile
index bd1a660d6e63..a75a5e93b8a0 100644
--- a/archivers/unrar-iconv/Makefile
+++ b/archivers/unrar-iconv/Makefile
@@ -13,6 +13,9 @@ MASTERDIR= ${.CURDIR}/../unrar
EXTRA_PATCHES= ${.CURDIR}/files/patch-iconv
+USE_ICONV= yes
+MAKE_ENV= LOCALBASE="${LOCALBASE}"
+
CONFLICTS= unrar-[0-9]* zh-unrar-[0-9]*
post-install:
diff --git a/archivers/unrar-iconv/files/patch-iconv b/archivers/unrar-iconv/files/patch-iconv
index 7bff2b2ff6dd..81e02a21b033 100644
--- a/archivers/unrar-iconv/files/patch-iconv
+++ b/archivers/unrar-iconv/files/patch-iconv
@@ -123,22 +123,23 @@
+#define MCHelpSwLO "\n lo<option> Encoding option {ignore,translit,<empty>}"
+#define MIconvCannotOpen "\nCannot open iconv to convert between '%s' and '%s' with option '%s'"
+#endif
---- makefile.unix 2008-05-31 14:18:14.000000000 +0800
-+++ makefile.unix 2008-06-27 17:03:22.459952295 +0800
+--- makefile.unix.orig 2008-10-09 17:43:06.000000000 +0400
++++ makefile.unix 2009-06-07 17:27:00.000000000 +0400
@@ -11,6 +11,13 @@
DEFINES=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
STRIP=strip
DESTDIR=/usr
+# iconv stuff. Remove #ICONV# to enable
+# where to get iconv.h
-+CXXFLAGS+= -I/usr/local/include
++CXXFLAGS+= -I$(LOCALBASE)/include
+# where to get libiconv.so*
-+LIBS+= -L/usr/local/lib -liconv
++LIBS+= -L$(LOCALBASE)/lib -liconv
+# enable iconv stuff
+DEFINES+= -DWITH_ICONV
# Linux using LCC
#CXX=lcc
+
--- os.hpp Tue Oct 4 11:57:54 2005
+++ os.hpp Mon Jan 16 18:04:41 2006
@@ -169,6 +169,10 @@