aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2016-04-23 23:08:18 +0800
committerswills <swills@FreeBSD.org>2016-04-23 23:08:18 +0800
commit7597141bed95d8b2fc8ab97dada31b533b339bc2 (patch)
tree76b9c18853da16b39d1ece5c2c9c60c794f61de1 /archivers
parent16454eb4627e76f0d38eff7f551d80e9217c27d3 (diff)
downloadfreebsd-ports-gnome-7597141bed95d8b2fc8ab97dada31b533b339bc2.tar.gz
freebsd-ports-gnome-7597141bed95d8b2fc8ab97dada31b533b339bc2.tar.zst
freebsd-ports-gnome-7597141bed95d8b2fc8ab97dada31b533b339bc2.zip
archivers/rubygem-ruby-xz: create port
These are simple Ruby bindings for the liblzma library (http://tukaani.org/xz/), which is best known for the extreme compression ratio. Since FFI is used to implement the bindings, no compilation is needed and they should work with JRuby as well. WWW: http://quintus.github.io/ruby-xz
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/rubygem-ruby-xz/Makefile15
-rw-r--r--archivers/rubygem-ruby-xz/distinfo2
-rw-r--r--archivers/rubygem-ruby-xz/pkg-descr6
4 files changed, 24 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index dde678b5db76..ae7d86bcb783 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -189,6 +189,7 @@
SUBDIR += rubygem-bzip2-ruby
SUBDIR += rubygem-libarchive
SUBDIR += rubygem-minitar
+ SUBDIR += rubygem-ruby-xz
SUBDIR += rubygem-rubyzip
SUBDIR += rubygem-rubyzip2
SUBDIR += rvm
diff --git a/archivers/rubygem-ruby-xz/Makefile b/archivers/rubygem-ruby-xz/Makefile
new file mode 100644
index 000000000000..60b18009fc84
--- /dev/null
+++ b/archivers/rubygem-ruby-xz/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+
+PORTNAME= ruby-xz
+PORTVERSION= 0.2.2
+CATEGORIES= archivers rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby bindings for the liblzma library
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/archivers/rubygem-ruby-xz/distinfo b/archivers/rubygem-ruby-xz/distinfo
new file mode 100644
index 000000000000..93cfc66feb8f
--- /dev/null
+++ b/archivers/rubygem-ruby-xz/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/ruby-xz-0.2.2.gem) = 6c482a4743ddfbb9b4ef892338eac5ddf90ad1da79f2c5c4e74cbb513e413055
+SIZE (rubygem/ruby-xz-0.2.2.gem) = 20480
diff --git a/archivers/rubygem-ruby-xz/pkg-descr b/archivers/rubygem-ruby-xz/pkg-descr
new file mode 100644
index 000000000000..0f9c2b9a528c
--- /dev/null
+++ b/archivers/rubygem-ruby-xz/pkg-descr
@@ -0,0 +1,6 @@
+These are simple Ruby bindings for the liblzma library
+(http://tukaani.org/xz/), which is best known for the extreme compression
+ratio. Since FFI is used to implement the bindings, no compilation is needed
+and they should work with JRuby as well.
+
+WWW: http://quintus.github.io/ruby-xz