aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2016-01-17 03:24:31 +0800
committermiwi <miwi@FreeBSD.org>2016-01-17 03:24:31 +0800
commita7b388de8349dde071a8ab198c5fde08b2f2a5b7 (patch)
tree3a599a96da60e92cbcf58165e6016c3481945da0 /archivers
parent1b2e85c4a72bbfb1920078d7074734626ac07275 (diff)
downloadfreebsd-ports-gnome-a7b388de8349dde071a8ab198c5fde08b2f2a5b7.tar.gz
freebsd-ports-gnome-a7b388de8349dde071a8ab198c5fde08b2f2a5b7.tar.zst
freebsd-ports-gnome-a7b388de8349dde071a8ab198c5fde08b2f2a5b7.zip
This is Python module for RAR archive reading. The interface is made
as zipfile like as possible. WWW: https://github.com/markokr/rarfile PR: 206306 Submitted by: Kevin Golding <ports@caomhin.org>
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-rarfile/Makefile21
-rw-r--r--archivers/py-rarfile/distinfo2
-rw-r--r--archivers/py-rarfile/pkg-descr4
4 files changed, 28 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index d9ff61fd06fd..9b90a71e7c1e 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -169,6 +169,7 @@
SUBDIR += py-lzma
SUBDIR += py-pyliblzma
SUBDIR += py-python-snappy
+ SUBDIR += py-rarfile
SUBDIR += qpress
SUBDIR += quazip
SUBDIR += quazip-qt5
diff --git a/archivers/py-rarfile/Makefile b/archivers/py-rarfile/Makefile
new file mode 100644
index 000000000000..665ff18497e8
--- /dev/null
+++ b/archivers/py-rarfile/Makefile
@@ -0,0 +1,21 @@
+# Created by: Kevin Golding <ports@caomhin.org>
+# $FreeBSD$
+
+PORTNAME= rarfile
+PORTVERSION= 2.7
+CATEGORIES= archivers python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@caomhin.org
+COMMENT= Python module for RAR archive reading
+
+LICENSE= ISCL
+
+RUN_DEPENDS= unrar:${PORTSDIR}/archivers/unrar
+
+NO_ARCH= yes
+USES= python:2.7+
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/archivers/py-rarfile/distinfo b/archivers/py-rarfile/distinfo
new file mode 100644
index 000000000000..af3e6bb79486
--- /dev/null
+++ b/archivers/py-rarfile/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rarfile-2.7.tar.gz) = 47148088ddb6c020774f4c38927fec9625ca33651bdc551bdaeafc78690b1635
+SIZE (rarfile-2.7.tar.gz) = 37515
diff --git a/archivers/py-rarfile/pkg-descr b/archivers/py-rarfile/pkg-descr
new file mode 100644
index 000000000000..cc780b342f81
--- /dev/null
+++ b/archivers/py-rarfile/pkg-descr
@@ -0,0 +1,4 @@
+This is Python module for RAR archive reading. The interface is made
+as zipfile like as possible.
+
+WWW: https://github.com/markokr/rarfile