aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2009-02-10 04:21:08 +0800
committergabor <gabor@FreeBSD.org>2009-02-10 04:21:08 +0800
commit40ed0260d92883dd78ce7b9b067fe4996fd452fb (patch)
tree9fcc4fbe6ee9a1a8307a00d6f6eb810ab5bae3f9 /archivers
parent9819c036d4fe1bd29fba76fe98e9f38ace20a6a3 (diff)
downloadfreebsd-ports-gnome-40ed0260d92883dd78ce7b9b067fe4996fd452fb.tar.gz
freebsd-ports-gnome-40ed0260d92883dd78ce7b9b067fe4996fd452fb.tar.zst
freebsd-ports-gnome-40ed0260d92883dd78ce7b9b067fe4996fd452fb.zip
A multi-threaded bzip2/bunzip2 filter that doesn't depend on the lseek()
system call and so isn't restricted to regular files. WWW: http://phptest11.atw.hu/
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/lbzip2/Makefile20
-rw-r--r--archivers/lbzip2/distinfo3
-rw-r--r--archivers/lbzip2/files/patch-Makefile21
-rw-r--r--archivers/lbzip2/pkg-descr4
5 files changed, 49 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index ee9c76e7548a..b9094ae87afc 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -44,6 +44,7 @@
SUBDIR += kio_p7zip
SUBDIR += kzip
SUBDIR += lbrate
+ SUBDIR += lbzip2
SUBDIR += lcab
SUBDIR += lha
SUBDIR += lha-ac
diff --git a/archivers/lbzip2/Makefile b/archivers/lbzip2/Makefile
new file mode 100644
index 000000000000..8b081b6d231e
--- /dev/null
+++ b/archivers/lbzip2/Makefile
@@ -0,0 +1,20 @@
+# New ports collection Makefile for: archivers/lbzip2
+# Date created: 7 Feb 2009
+# Whom: Gabor Kovesdan <gabor@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= lbzip2
+PORTVERSION= 0.13
+CATEGORIES= archivers
+MASTER_SITES= http://lacos.web.elte.hu/pub/lbzip2/
+
+MAINTAINER= gabor@FreeBSD.org
+COMMENT= A multi-threaded bzip2/bunzip2 filter
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_FILES= bin/lbzip2
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lbzip2 ${PREFIX}/bin/lbzip2
+
+.include <bsd.port.mk>
diff --git a/archivers/lbzip2/distinfo b/archivers/lbzip2/distinfo
new file mode 100644
index 000000000000..288516980c0c
--- /dev/null
+++ b/archivers/lbzip2/distinfo
@@ -0,0 +1,3 @@
+MD5 (lbzip2-0.13.tar.gz) = d0e136e40de76066f5cde89daa3e373a
+SHA256 (lbzip2-0.13.tar.gz) = 12db87e77da94c5446202bf67e3b13247254776fc02840fa7e21008533eac7a9
+SIZE (lbzip2-0.13.tar.gz) = 60912
diff --git a/archivers/lbzip2/files/patch-Makefile b/archivers/lbzip2/files/patch-Makefile
new file mode 100644
index 000000000000..e3937a991238
--- /dev/null
+++ b/archivers/lbzip2/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig 2009-01-25 18:27:52.000000000 +0100
++++ Makefile 2009-02-07 18:56:15.000000000 +0100
+@@ -1,15 +1,10 @@
+ # Makefile,v 1.8 2009-01-25 17:27:52 lacos Exp
+ .POSIX:
+
+-CC=gcc
+-CFLAGS=$$($(SHELL) lfs.sh CFLAGS) -D _XOPEN_SOURCE=500 -pipe -ansi -pedantic \
+- -O3
++LDFLAGS+= -s
++LIBS+= -l pthread -l bz2
+
+-
+-
+-
+-LDFLAGS=-s $$($(SHELL) lfs.sh LDFLAGS)
+-LIBS=-l pthread -l bz2 $$($(SHELL) lfs.sh LIBS)
++all: lbzip2
+
+ lbzip2: main.o lbzip2.o lbunzip2.o lbunzip2_single.o lacos_rbtree.o
+ $(CC) -o lbzip2 $(LDFLAGS) main.o lbzip2.o lbunzip2.o \
diff --git a/archivers/lbzip2/pkg-descr b/archivers/lbzip2/pkg-descr
new file mode 100644
index 000000000000..20e74ca0208d
--- /dev/null
+++ b/archivers/lbzip2/pkg-descr
@@ -0,0 +1,4 @@
+A multi-threaded bzip2/bunzip2 filter that doesn't depend on the lseek()
+system call and so isn't restricted to regular files.
+
+WWW: http://phptest11.atw.hu/