aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-12-27 10:16:12 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-12-27 10:16:12 +0800
commit07c1fa3058198c1ec2771a081b6bb95ae0cdda3e (patch)
tree736db53cadc0503b3dfd0fcdb412acd537d8affb /archivers
parent89b666e6bceb1cccfb429d0f2f3b96dbb585518b (diff)
downloadfreebsd-ports-gnome-07c1fa3058198c1ec2771a081b6bb95ae0cdda3e.tar.gz
freebsd-ports-gnome-07c1fa3058198c1ec2771a081b6bb95ae0cdda3e.tar.zst
freebsd-ports-gnome-07c1fa3058198c1ec2771a081b6bb95ae0cdda3e.zip
- Convert to new LIB_DEPENDS format
- Remove outdated OSVERSION check
Diffstat (limited to 'archivers')
-rw-r--r--archivers/p5-Compress-Raw-Lzma/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/archivers/p5-Compress-Raw-Lzma/Makefile b/archivers/p5-Compress-Raw-Lzma/Makefile
index bd5a54488d69..4a674f8890e2 100644
--- a/archivers/p5-Compress-Raw-Lzma/Makefile
+++ b/archivers/p5-Compress-Raw-Lzma/Makefile
@@ -19,20 +19,20 @@ TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
USE_PERL5= configure
USES= perl5
+LZMA_DEPEND?= sys
+
.include <bsd.port.pre.mk>
.if (${ARCH} == "sparc64")
LZMA_DEPEND= xz
.endif
-.if (${OSVERSION} > 900012) || ((${OSVERSION} > 800505) && (${OSVERSION} < 900000))
-LZMA_DEPEND?= sys
-.else
-LZMA_DEPEND?= xz
+.if ${LZMA_DEPEND} == "lzmalib"
+LIB_DEPENDS+= liblzma.so.1:${PORTSDIR}/archivers/lzmalib
.endif
-.if (${LZMA_DEPEND} == "xz") || (${LZMA_DEPEND} == "lzmalib")
-LIB_DEPENDS+= liblzma.so:${PORTSDIR}/archivers/${LZMA_DEPEND}
+.if ${LZMA_DEPEND} == "xz"
+LIB_DEPENDS+= liblzma.so.5:${PORTSDIR}/archivers/xz
.endif
pre-build: