aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2017-04-16 20:03:05 +0800
committerdanfe <danfe@FreeBSD.org>2017-04-16 20:03:05 +0800
commit12243ae19a8ece25cffd8a3ce1e85544deab4d9f (patch)
tree5dfd806b806666aa4f135d4e56cc3949235c9614 /archivers
parent4caedb25329f6f262551a898120764b52f62be27 (diff)
downloadfreebsd-ports-gnome-12243ae19a8ece25cffd8a3ce1e85544deab4d9f.tar.gz
freebsd-ports-gnome-12243ae19a8ece25cffd8a3ce1e85544deab4d9f.tar.zst
freebsd-ports-gnome-12243ae19a8ece25cffd8a3ce1e85544deab4d9f.zip
Remove dependency on GNU make(1).
It turns out that GNU make(1) is only required because their make(1) spells target dependencies as $^ while ours use $>. This change makes the pbzip2's Makefile both GNU and BSD make(1) friendly at the same time. This is required to be able to use `archivers/pbzip2' port as a PKG_DEPEND. Approved by: farrokhi (maintainer)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/pbzip2/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/archivers/pbzip2/Makefile b/archivers/pbzip2/Makefile
index a6de83e47f96..317c0a4e8e79 100644
--- a/archivers/pbzip2/Makefile
+++ b/archivers/pbzip2/Makefile
@@ -11,12 +11,15 @@ COMMENT= Parallel BZIP2
LICENSE= BSD4CLAUSE
-USES= gmake
MAKE_ARGS= CFLAGS="${CXXFLAGS}" CC="${CXX}"
PLIST_FILES= bin/pbzip2 bin/pbunzip2 \
man/man1/pbzip2.1.gz man/man1/pbunzip2.1.gz
+post-patch:
+# Spell target sources to be understood by both BSD and GNU make(1)
+ @${REINPLACE_CMD} -e 's,$$^,$$>&,' ${WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
${LN} -sf ${PORTNAME} ${STAGEDIR}${PREFIX}/bin/pbunzip2