aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2008-04-04 05:43:38 +0800
committerache <ache@FreeBSD.org>2008-04-04 05:43:38 +0800
commit24f2ef668b712345c7077e3c7e25a932983fb9eb (patch)
treef2a29a352c8091681c46e493b5ff04fe9d22ea4e /archivers
parent0d2fdb584c6eeb1647a921d03b7aeecb78805e65 (diff)
downloadfreebsd-ports-gnome-24f2ef668b712345c7077e3c7e25a932983fb9eb.tar.gz
freebsd-ports-gnome-24f2ef668b712345c7077e3c7e25a932983fb9eb.tar.zst
freebsd-ports-gnome-24f2ef668b712345c7077e3c7e25a932983fb9eb.zip
Honor CC
Reorganize LOCAL_UNZIP PR: 122389 Submitted by: Frank Fenor <frank@fenor.de> (CC part)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/unzip/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/archivers/unzip/Makefile b/archivers/unzip/Makefile
index 5eb91103569c..536a58c1b563 100644
--- a/archivers/unzip/Makefile
+++ b/archivers/unzip/Makefile
@@ -7,7 +7,7 @@
PORTNAME= unzip
PORTVERSION= 5.52
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES?= archivers
MASTER_SITES= ftp://ftp.info-zip.org/pub/infozip/src/ ${MASTER_SITE_TEX_CTAN}
MASTER_SITE_SUBDIR= tools/zip/info-zip/src
@@ -18,19 +18,21 @@ COMMENT?= List, test and extract compressed files in a ZIP archive
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKEFILE= unix/Makefile
-MAKE_ENV= LOCAL_UNZIP="${CFLAGS} -DUSE_UNSHRINK"
PLIST_FILES= bin/unzip bin/funzip bin/unzipsfx bin/zipgrep bin/zipinfo
PORTDOCS= README WHERE
MAN1= funzip.1 unzip.1 unzipsfx.1 zipgrep.1 zipinfo.1
+
CFLAGS+= -D_FILE_OFFSET_BITS=64
+LOCAL_UNZIP= ${CFLAGS} -DACORN_FTYPE_NFS -DWILD_STOP_AT_DIR
.if defined(WITH_UNZIP_UNREDUCE)
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} unreduce_full.zip
EXTRACT_ONLY= ${PORTNAME}552.tar.gz
-MAKE_ENV= LOCAL_UNZIP="${CFLAGS} \
- -DUSE_SMITH_CODE -DACORN_FTYPE_NFS -DWILD_STOP_AT_DIR"
+LOCAL_UNZIP+= -DUSE_SMITH_CODE
.endif
+MAKE_ENV= CC="${CC}" LOCAL_UNZIP="${LOCAL_UNZIP}"
+
.ifdef USE_UNZIP
.error You have `USE_UNZIP' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif