aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /archivers
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'archivers')
-rw-r--r--archivers/ark-kde4/Makefile4
-rw-r--r--archivers/ark/Makefile4
-rw-r--r--archivers/kf5-karchive/Makefile4
-rw-r--r--archivers/quazip/Makefile8
4 files changed, 11 insertions, 9 deletions
diff --git a/archivers/ark-kde4/Makefile b/archivers/ark-kde4/Makefile
index 51c72818d7d3..82f77193c51e 100644
--- a/archivers/ark-kde4/Makefile
+++ b/archivers/ark-kde4/Makefile
@@ -14,10 +14,10 @@ LIB_DEPENDS= libqjson.so:devel/qjson@qt4
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake:outsource kde:4 libarchive cpe tar:xz
+USES= cmake:outsource kde:4 libarchive cpe qt:4 tar:xz
USE_KDE= automoc4 kdelibs libkonq
CPE_VENDOR= kde
-USE_QT4= qtestlib qmake_build moc_build rcc_build uic_build
+USE_QT= qtestlib qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
OPTIONS_DEFINE= 7ZIP RAR ZIP
diff --git a/archivers/ark/Makefile b/archivers/ark/Makefile
index ce6264361da3..0a42374e49d0 100644
--- a/archivers/ark/Makefile
+++ b/archivers/ark/Makefile
@@ -10,12 +10,12 @@ COMMENT= Archiving tool for KDE
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake:outsource gettext libarchive kde:5 tar:xz
+USES= cmake:outsource gettext libarchive kde:5 qt:5 tar:xz
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons doctools ecm i18n iconthemes \
itemmodels itemviews jobwidgets khtml kio parts pty service \
solid sonnet textwidgets widgetsaddons xmlgui
-USE_QT5= concurrent core dbus gui network widgets xml \
+USE_QT= concurrent core dbus gui network widgets xml \
buildtools_build qmake_build
USE_LDCONFIG= yes
diff --git a/archivers/kf5-karchive/Makefile b/archivers/kf5-karchive/Makefile
index 5cba965b7a85..7c8df0a6f389 100644
--- a/archivers/kf5-karchive/Makefile
+++ b/archivers/kf5-karchive/Makefile
@@ -11,8 +11,8 @@ COMMENT= KF5 library that provides classes for handling archive formats
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING.LIB
-USES= cmake:outsource compiler:c++11-lib kde:5 tar:xz
+USES= cmake:outsource compiler:c++11-lib kde:5 qt:5 tar:xz
USE_KDE= ecm
-USE_QT5= buildtools_build core qmake_build
+USE_QT= buildtools_build core qmake_build
.include <bsd.port.mk>
diff --git a/archivers/quazip/Makefile b/archivers/quazip/Makefile
index e104a74238ba..3cb4c3500a8c 100644
--- a/archivers/quazip/Makefile
+++ b/archivers/quazip/Makefile
@@ -16,14 +16,16 @@ LICENSE= LGPL21
FLAVORS= qt4 qt5
FLAVOR?= ${FLAVORS:[1]}
-USES= cmake:outsource
+USES= cmake:outsource
USE_LDCONFIG= yes
. if ${FLAVOR} == qt4
-USE_QT4= corelib moc_build network_build qmake_build rcc_build uic_build
+USES+= qt:4
+USE_QT= corelib moc_build network_build qmake_build rcc_build uic_build
CMAKE_ARGS= -DBUILD_WITH_QT4:BOOL=TRUE
. else
-USE_QT5= core buildtools_build qmake_build
+USES+= qt:5
+USE_QT= core buildtools_build qmake_build
CMAKE_ARGS= -DBUILD_WITH_QT4:BOOL=FALSE
QTVER_SUFFIX= 5
. endif