aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-06-21 23:42:17 +0800
committergarga <garga@FreeBSD.org>2006-06-21 23:42:17 +0800
commit3f42c381772d57b56db476b0495820b89e13dcf0 (patch)
treeeb9afbb6bf82e6e9a352b3b77e870868b4ee1a6c /archivers
parent17bff6398c648d4dad413b476e986673ca71ee5e (diff)
downloadfreebsd-ports-gnome-3f42c381772d57b56db476b0495820b89e13dcf0.tar.gz
freebsd-ports-gnome-3f42c381772d57b56db476b0495820b89e13dcf0.tar.zst
freebsd-ports-gnome-3f42c381772d57b56db476b0495820b89e13dcf0.zip
Add fpc-unzip , free Pascal routines for unzipping zip files.
PR: ports/98679 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/fpc-unzip/Makefile19
2 files changed, 20 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 903ef241d61d..50d3f60414e0 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -22,6 +22,7 @@
SUBDIR += fastjar
SUBDIR += file-roller
SUBDIR += fpc-paszlib
+ SUBDIR += fpc-unzip
SUBDIR += freeze
SUBDIR += gtar
SUBDIR += gzip
diff --git a/archivers/fpc-unzip/Makefile b/archivers/fpc-unzip/Makefile
new file mode 100644
index 000000000000..23d23aaee449
--- /dev/null
+++ b/archivers/fpc-unzip/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: fpc-unzip
+# Date created: 2006-06-05
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= archivers lang
+PKGNAMESUFFIX= -unzip
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Free Pascal routines for unzipping zip files
+
+RUN_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
+ unzip:${PORTSDIR}/archivers/unzip
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+
+.include "${MASTERDIR}/Makefile"