aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2004-11-25 23:27:27 +0800
committerfjoe <fjoe@FreeBSD.org>2004-11-25 23:27:27 +0800
commita3797837502957c7c6fabc650888c791605e863a (patch)
tree4c261a434ca48bb9d75365868c8becfbf5e5d1a8 /archivers
parent76b1b828508de9669c518f9e77bf57108ab8f1e4 (diff)
downloadfreebsd-ports-gnome-a3797837502957c7c6fabc650888c791605e863a.tar.gz
freebsd-ports-gnome-a3797837502957c7c6fabc650888c791605e863a.tar.zst
freebsd-ports-gnome-a3797837502957c7c6fabc650888c791605e863a.zip
Allow mspack.h to be included in C++ source code
(replace "this" with "self").
Diffstat (limited to 'archivers')
-rw-r--r--archivers/libmspack/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/archivers/libmspack/Makefile b/archivers/libmspack/Makefile
index 1e132669bcf0..b7b8518b66d2 100644
--- a/archivers/libmspack/Makefile
+++ b/archivers/libmspack/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libmspack
PORTVERSION= 0.0.20040308
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= http://www.kyz.uklinux.net/downloads/
DISTNAME= ${PORTNAME}-${PORTVERSION}alpha
@@ -14,8 +15,13 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}alpha
MAINTAINER= fjoe@FreeBSD.org
COMMENT= A library for Microsoft compression formats
+USE_REINPLACE= yes
USE_LIBTOOL_VER= 15
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's,\*this,*self,'\
+ -e 's,@param\( *\)this,@param\1self,' ${WRKSRC}/mspack/mspack.h
+
.include <bsd.port.mk>