aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2018-06-15 05:18:54 +0800
committerrakuco <rakuco@FreeBSD.org>2018-06-15 05:18:54 +0800
commitecfe533ea71190431e47a2db4ce2f90a3eb10aeb (patch)
treea30c3b3c19eaed6cb62c4ebd5e0a2e2cc593245c /archivers
parent1a79998f19c94c734ae0b169f848b7f537e7874a (diff)
downloadfreebsd-ports-gnome-ecfe533ea71190431e47a2db4ce2f90a3eb10aeb.tar.gz
freebsd-ports-gnome-ecfe533ea71190431e47a2db4ce2f90a3eb10aeb.tar.zst
freebsd-ports-gnome-ecfe533ea71190431e47a2db4ce2f90a3eb10aeb.zip
Update to 1.5.1.
Upstream has switched to CMake, so follow suit here (and explicitly disable crypto backends other than OpenSSL for AES support). The port also depends on Perl for testing, so add the missing dependency. Based on an initial patch by danfe@. Submitted by: danfe (initial version)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/libzip/Makefile12
-rw-r--r--archivers/libzip/distinfo6
-rw-r--r--archivers/libzip/files/patch-CMakeLists.txt12
-rw-r--r--archivers/libzip/pkg-plist9
4 files changed, 28 insertions, 11 deletions
diff --git a/archivers/libzip/Makefile b/archivers/libzip/Makefile
index ea3563fc31aa..a1367e6bfb56 100644
--- a/archivers/libzip/Makefile
+++ b/archivers/libzip/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libzip
-PORTVERSION= 1.3.2
+PORTVERSION= 1.5.1
CATEGORIES= archivers devel
MASTER_SITES= https://libzip.org/download/
@@ -14,11 +14,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
CPE_VENDOR= nih
-GNU_CONFIGURE= yes
-USES= cpe libtool pathfix perl5 tar:xz
-USE_PERL5= build
+USES= cmake:outsource cpe perl5 ssl tar:xz
USE_LDCONFIG= yes
-INSTALL_TARGET= install-strip
-TEST_TARGET= check
+USE_PERL5= test
+TEST_TARGET= test
+
+CMAKE_OFF= ENABLE_COMMONCRYPTO ENABLE_GNUTLS
.include <bsd.port.mk>
diff --git a/archivers/libzip/distinfo b/archivers/libzip/distinfo
index a8da6d2a75ce..e0595f964289 100644
--- a/archivers/libzip/distinfo
+++ b/archivers/libzip/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1511266116
-SHA256 (libzip-1.3.2.tar.xz) = 6277845010dbc20e281a77e637c97765c1323d67df4d456fd942f525ea86e185
-SIZE (libzip-1.3.2.tar.xz) = 942756
+TIMESTAMP = 1523434126
+SHA256 (libzip-1.5.1.tar.xz) = 04ea35b6956c7b3453f1ed3f3fe40e3ddae1f43931089124579e8384e79ed372
+SIZE (libzip-1.5.1.tar.xz) = 717908
diff --git a/archivers/libzip/files/patch-CMakeLists.txt b/archivers/libzip/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..ac70abe13612
--- /dev/null
+++ b/archivers/libzip/files/patch-CMakeLists.txt
@@ -0,0 +1,12 @@
+Do not set RPATH on FreeBSD either.
+--- CMakeLists.txt.orig 2018-06-14 20:07:27 UTC
++++ CMakeLists.txt
+@@ -224,7 +224,7 @@ endif(WIN32)
+ ADD_DEFINITIONS("-DHAVE_CONFIG_H")
+
+ # rpath handling: use rpath in installed binaries
+-IF(NOT CMAKE_SYSTEM_NAME MATCHES Linux)
++IF(NOT CMAKE_SYSTEM_NAME MATCHES "FreeBSD|Linux")
+ SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")
+ SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+ ENDIF()
diff --git a/archivers/libzip/pkg-plist b/archivers/libzip/pkg-plist
index 553957ee409c..6da94b00fef8 100644
--- a/archivers/libzip/pkg-plist
+++ b/archivers/libzip/pkg-plist
@@ -3,10 +3,9 @@ bin/zipmerge
bin/ziptool
include/zip.h
include/zipconf.h
-lib/libzip.a
lib/libzip.so
lib/libzip.so.5
-lib/libzip.so.5.0.0
+lib/libzip.so.5.0
libdata/pkgconfig/libzip.pc
man/man1/zipcmp.1.gz
man/man1/zipmerge.1.gz
@@ -84,12 +83,18 @@ man/man3/zip_set_file_comment.3.gz
man/man3/zip_set_file_compression.3.gz
man/man3/zip_source.3.gz
man/man3/zip_source_begin_write.3.gz
+man/man3/zip_source_begin_write_cloning.3.gz
man/man3/zip_source_buffer.3.gz
+man/man3/zip_source_buffer_create.3.gz
+man/man3/zip_source_buffer_fragment.3.gz
+man/man3/zip_source_buffer_fragment_create.3.gz
man/man3/zip_source_close.3.gz
man/man3/zip_source_commit_write.3.gz
man/man3/zip_source_error.3.gz
man/man3/zip_source_file.3.gz
+man/man3/zip_source_file_create.3.gz
man/man3/zip_source_filep.3.gz
+man/man3/zip_source_filep_create.3.gz
man/man3/zip_source_free.3.gz
man/man3/zip_source_function.3.gz
man/man3/zip_source_function_create.3.gz