aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-14 17:56:58 +0800
committerclsung <clsung@FreeBSD.org>2006-08-14 17:56:58 +0800
commit30da2b610139191d26e19268dc9011f760fa3c17 (patch)
tree33c021ff0a9d319c5b8744227b6b27ceea5a9b3b /archivers
parent795f397e9681c9841a585258ede7aa8491d50be0 (diff)
downloadfreebsd-ports-gnome-30da2b610139191d26e19268dc9011f760fa3c17.tar.gz
freebsd-ports-gnome-30da2b610139191d26e19268dc9011f760fa3c17.tar.zst
freebsd-ports-gnome-30da2b610139191d26e19268dc9011f760fa3c17.zip
- s,INSTALLS_SHLIB,USE_LDCONFIG,g
Diffstat (limited to 'archivers')
-rw-r--r--archivers/libarc/Makefile2
-rw-r--r--archivers/libcabinet/Makefile2
-rw-r--r--archivers/libcomprex/Makefile2
-rw-r--r--archivers/rpm/Makefile2
-rw-r--r--archivers/ucl/Makefile2
-rw-r--r--archivers/zipios++/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/archivers/libarc/Makefile b/archivers/libarc/Makefile
index e85be38bed34..ce1c38aaf4da 100644
--- a/archivers/libarc/Makefile
+++ b/archivers/libarc/Makefile
@@ -20,7 +20,7 @@ SOVERSION= 1
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -I." LN="${LN} -sf" \
SOLIB="${SOLIB}" SOVERSION="${SOVERSION}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
do-install:
$(INSTALL_PROGRAM) ${WRKSRC}/arccat $(PREFIX)/bin
diff --git a/archivers/libcabinet/Makefile b/archivers/libcabinet/Makefile
index ec68e2ebd03f..c5bdcc4785e3 100644
--- a/archivers/libcabinet/Makefile
+++ b/archivers/libcabinet/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.bsd-geek.de/FreeBSD/distfiles/
MAINTAINER= ports@FreeBSD.org
COMMENT= A portable library and utility to use Microsoft cabinet files (.cab)
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
SRCFILE= ${WRKSRC}/listcab.cpp
PROGFILE= ${SRCFILE:S/.cpp$//}
diff --git a/archivers/libcomprex/Makefile b/archivers/libcomprex/Makefile
index a6cc8208558c..4fece4645a04 100644
--- a/archivers/libcomprex/Makefile
+++ b/archivers/libcomprex/Makefile
@@ -24,7 +24,7 @@ USE_AUTOTOOLS= libltdl:15
USE_GNOME= gnomehack gnometarget pkgconfig
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
diff --git a/archivers/rpm/Makefile b/archivers/rpm/Makefile
index 93d6b31cefec..35e82b4815ab 100644
--- a/archivers/rpm/Makefile
+++ b/archivers/rpm/Makefile
@@ -25,7 +25,7 @@ USE_AUTOTOOLS= automake:14 autoconf:213 libtool:15
CONFIGURE_ARGS= --with-glob
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl -liconv"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAKE_ENV= OLD_PO_FILE_INPUT=1
MAN1= gendiff.1
diff --git a/archivers/ucl/Makefile b/archivers/ucl/Makefile
index 9b615580ca5a..bdf441fe5997 100644
--- a/archivers/ucl/Makefile
+++ b/archivers/ucl/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.oberhumer.com/opensource/ucl/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= A data compression library with low memory usage
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/archivers/zipios++/Makefile b/archivers/zipios++/Makefile
index 3ab6b23610e5..593d7442af39 100644
--- a/archivers/zipios++/Makefile
+++ b/archivers/zipios++/Makefile
@@ -17,7 +17,7 @@ COMMENT= A java.util.zip-like C++ library for reading and writing Zip files
USE_GNOME= gnometarget
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
# port don't strictly need it, but Wesnoth use it so must we
USE_GCC= 3.4
USE_AUTOTOOLS= automake:19:env