aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authoravl <avl@FreeBSD.org>2009-10-03 18:47:15 +0800
committeravl <avl@FreeBSD.org>2009-10-03 18:47:15 +0800
commit44e72d9d233b56a0c84f23ceb65a6676236a01a7 (patch)
tree0e92f14d1a967c83c2fd865667e5d70ed03c5daa /archivers
parent2423a4b7552c84c24b59d962ff154bfe8f14d40a (diff)
downloadfreebsd-ports-gnome-44e72d9d233b56a0c84f23ceb65a6676236a01a7.tar.gz
freebsd-ports-gnome-44e72d9d233b56a0c84f23ceb65a6676236a01a7.tar.zst
freebsd-ports-gnome-44e72d9d233b56a0c84f23ceb65a6676236a01a7.zip
- Speed up build phase
Approved by: tabthorpe, glarkin (mentors, implicit)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/py-librtfcomp/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/archivers/py-librtfcomp/Makefile b/archivers/py-librtfcomp/Makefile
index 465f771a509a..cec8437c3f1f 100644
--- a/archivers/py-librtfcomp/Makefile
+++ b/archivers/py-librtfcomp/Makefile
@@ -22,6 +22,13 @@ PLIST= ${.CURDIR}/pkg-plist
RTFCOMP_SLAVE= pythonb
+pre-patch:
+ @${REINPLACE_CMD} -e 's|$$(top_builddir)/src/librtfcomp.la|${LOCALBASE}/lib/librtfcomp.la|g' \
+ ${WRKSRC}/python/Makefile.in
+
+do-build:
+ @(cd ${WRKSRC}/python && ${MAKE})
+
do-install:
@(cd ${WRKSRC}/python && ${MAKE} install)