aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
committerale <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
commit48d5fb51023dbbe8f2a70121c289e1849e7e14eb (patch)
treefd816d2c8b34ef7db2d6bcabe7358eaa7fb2d04f /archivers
parent19160cd533a64299fc9d3710c4d21307ce72df91 (diff)
downloadfreebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.tar.gz
freebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.tar.zst
freebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.zip
Welcome PHP 5.5!
Future steps: - rename current php5 ports to php54 - make php55 the default one after an exp-run
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile4
-rw-r--r--archivers/php55-bz2/Makefile10
-rw-r--r--archivers/php55-phar/Makefile10
-rw-r--r--archivers/php55-phar/files/patch-config.m441
-rw-r--r--archivers/php55-phar/files/patch-phar.c11
-rw-r--r--archivers/php55-zip/Makefile10
-rw-r--r--archivers/php55-zip/files/patch-config.m410
-rw-r--r--archivers/php55-zlib/Makefile10
-rw-r--r--archivers/php55-zlib/files/patch-zlib.c10
9 files changed, 116 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 905ba4fabb3b..87b1cadf0e70 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -144,6 +144,10 @@
SUBDIR += php53-phar
SUBDIR += php53-zip
SUBDIR += php53-zlib
+ SUBDIR += php55-bz2
+ SUBDIR += php55-phar
+ SUBDIR += php55-zip
+ SUBDIR += php55-zlib
SUBDIR += pigz
SUBDIR += pixz
SUBDIR += plzip
diff --git a/archivers/php55-bz2/Makefile b/archivers/php55-bz2/Makefile
new file mode 100644
index 000000000000..2806e4e3594a
--- /dev/null
+++ b/archivers/php55-bz2/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -bz2
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php55-phar/Makefile b/archivers/php55-phar/Makefile
new file mode 100644
index 000000000000..11c33c141a63
--- /dev/null
+++ b/archivers/php55-phar/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -phar
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php55-phar/files/patch-config.m4 b/archivers/php55-phar/files/patch-config.m4
new file mode 100644
index 000000000000..1a981bfefdc1
--- /dev/null
+++ b/archivers/php55-phar/files/patch-config.m4
@@ -0,0 +1,41 @@
+--- config.m4.orig 2011-11-25 15:31:20.000000000 +0100
++++ config.m4 2011-11-25 15:47:45.000000000 +0100
+@@ -4,8 +4,38 @@
+ PHP_ARG_ENABLE(phar, for phar archive support,
+ [ --disable-phar Disable phar support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir PHAR: pcre install prefix], no, no)
++
++
+ if test "$PHP_PHAR" != "no"; then
++
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ PHP_NEW_EXTENSION(phar, util.c tar.c zip.c stream.c func_interceptors.c dirstream.c phar.c phar_object.c phar_path_check.c, $ext_shared)
++ PHP_HASH=yes
+ AC_MSG_CHECKING([for phar openssl support])
+ if test "$PHP_HASH_SHARED" != "yes"; then
+ if test "$PHP_HASH" != "no"; then
diff --git a/archivers/php55-phar/files/patch-phar.c b/archivers/php55-phar/files/patch-phar.c
new file mode 100644
index 000000000000..231ec40a8423
--- /dev/null
+++ b/archivers/php55-phar/files/patch-phar.c
@@ -0,0 +1,11 @@
+--- phar.c.orig 2011-11-25 15:38:44.000000000 +0100
++++ phar.c 2011-11-25 15:39:01.000000000 +0100
+@@ -3716,7 +3716,7 @@
+ ZEND_MOD_OPTIONAL("openssl")
+ ZEND_MOD_OPTIONAL("zlib")
+ ZEND_MOD_OPTIONAL("standard")
+-#if defined(HAVE_HASH) && !defined(COMPILE_DL_HASH)
++#if defined(HAVE_HASH)
+ ZEND_MOD_REQUIRED("hash")
+ #endif
+ #if HAVE_SPL
diff --git a/archivers/php55-zip/Makefile b/archivers/php55-zip/Makefile
new file mode 100644
index 000000000000..5292174544df
--- /dev/null
+++ b/archivers/php55-zip/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -zip
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php55-zip/files/patch-config.m4 b/archivers/php55-zip/files/patch-config.m4
new file mode 100644
index 000000000000..a87640ff160d
--- /dev/null
+++ b/archivers/php55-zip/files/patch-config.m4
@@ -0,0 +1,10 @@
+--- config.m4.orig 2009-04-09 16:16:30.000000000 +0200
++++ config.m4 2009-04-09 16:17:02.000000000 +0200
+@@ -65,6 +65,7 @@
+ #endif
+ ],[
+ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
+ ],[
+ PHP_PCRE_REGEX=no
+ ])
diff --git a/archivers/php55-zlib/Makefile b/archivers/php55-zlib/Makefile
new file mode 100644
index 000000000000..8183cdeeb061
--- /dev/null
+++ b/archivers/php55-zlib/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -zlib
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php55-zlib/files/patch-zlib.c b/archivers/php55-zlib/files/patch-zlib.c
new file mode 100644
index 000000000000..0e88fee9c5bf
--- /dev/null
+++ b/archivers/php55-zlib/files/patch-zlib.c
@@ -0,0 +1,10 @@
+--- zlib.c.orig 2012-07-09 15:25:31.000000000 +0200
++++ zlib.c 2012-07-09 15:26:07.000000000 +0200
+@@ -957,6 +957,7 @@
+ /* {{{ PHP_RINIT_FUNCTION */
+ static PHP_RINIT_FUNCTION(zlib)
+ {
++ ZLIBG(output_compression) = 0;
+ ZLIBG(compression_coding) = 0;
+
+ php_zlib_output_compression_start(TSRMLS_C);