aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-17 06:21:55 +0800
committermarino <marino@FreeBSD.org>2014-07-17 06:21:55 +0800
commit6929996ad635d30544c705bfdd3b757560b39992 (patch)
tree8625f13992aed7e836a05ddef34872990cf2f38e /archivers
parent4b6a5ddf30a40e75f4cde9ce005d55b32c935ea0 (diff)
downloadfreebsd-ports-gnome-6929996ad635d30544c705bfdd3b757560b39992.tar.gz
freebsd-ports-gnome-6929996ad635d30544c705bfdd3b757560b39992.tar.zst
freebsd-ports-gnome-6929996ad635d30544c705bfdd3b757560b39992.zip
archivers/liborange: Unbreak port by working around configure flaw
The configure error "Not configured with libgsf or libole2 but that's needed for MSI support" is caused by using the wrong configure option of MSI that was introduced in last commit. Changing to MSI_CONFIGURE_ENABLE=libgsf to MSI_CONFIGURE_WITH=libgsf should have solved the problem, but unfortunately there is a logic flaw in the configure script. If --without-libgsf is passed to it, it mistakenly tries to find it anyway with pkgconfig and then fails. The way to fix this properly is to patch the configure script, but I am going to cheat by making libgsf an unconditional requirement as it was before adamw fixed the options reversal.
Diffstat (limited to 'archivers')
-rw-r--r--archivers/liborange/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/archivers/liborange/Makefile b/archivers/liborange/Makefile
index 98ae3dcb9514..d293a633f7c2 100644
--- a/archivers/liborange/Makefile
+++ b/archivers/liborange/Makefile
@@ -3,13 +3,14 @@
PORTNAME= liborange
PORTVERSION= 0.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= archivers
MASTER_SITES= SF/synce/Orange/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Library to extract CAB files from self-extracting installers
+LIB_DEPENDS= libgsf-1.so:${PORTSDIR}/devel/libgsf
RUN_DEPENDS= cabextract:${PORTSDIR}/archivers/cabextract \
unzip:${PORTSDIR}/archivers/unzip
@@ -25,9 +26,11 @@ MSI_DESC= Build with expermential MSI support
GNU_CONFIGURE= yes
USES= iconv libtool pathfix pkgconfig
CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -lgsf-1
USE_LDCONFIG= yes
+CONFIGURE_ARGS+= --with-libgsf
+
LIBSYNCE_LIB_DEPENDS= libsynce.so:${PORTSDIR}/palm/synce-libsynce
LIBSYNCE_CONFIGURE_WITH= libsynce
@@ -41,8 +44,7 @@ INNO_CONFIGURE_ENABLE= inno
VISE_CONFIGURE_ENABLE= vise
-MSI_LIB_DEPENDS= libgsf-1.so.114:${PORTSDIR}/devel/libgsf
-MSI_CONFIGURE_ENABLE= msi libgsf
+MSI_CONFIGURE_ENABLE= msi
.include <bsd.port.options.mk>