aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-09-14 21:32:06 +0800
committersobomax <sobomax@FreeBSD.org>2002-09-14 21:32:06 +0800
commit7c5bdc9e42725790d9930beeb578c30ebc8ce8a9 (patch)
tree9ea2ff2cc7182f0fa38f332ffb8c81d1929f4eeb /archivers
parenta33bc26ff1a1f6aaf0830cba9032d189c98a2ee8 (diff)
downloadfreebsd-ports-gnome-7c5bdc9e42725790d9930beeb578c30ebc8ce8a9.tar.gz
freebsd-ports-gnome-7c5bdc9e42725790d9930beeb578c30ebc8ce8a9.tar.zst
freebsd-ports-gnome-7c5bdc9e42725790d9930beeb578c30ebc8ce8a9.zip
Due to popular demant into each port which might be inserted into dependency
list by bsd.port.mk insert anti foot-shooting device, which prevents infinite fork loop when the user defines corresponding USE_XXX in global make.conf, command line or environment. Similar devices should probably be inserted into ports that might be inserted into dependency list by others bsd.foo.mk files (bsd.ruby.mk, bsd.python.mk and so on.)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/bzip2/Makefile4
-rw-r--r--archivers/unzip/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/archivers/bzip2/Makefile b/archivers/bzip2/Makefile
index c1928f39c43f..04d2fe27dbe7 100644
--- a/archivers/bzip2/Makefile
+++ b/archivers/bzip2/Makefile
@@ -27,6 +27,10 @@ MLINKS= bzip2.1 bunzip2.1 bzip2.1 bzcat.1 bzip2.1 bz2cat.1 \
bzgrep.1 bzfgrep.1 \
bzmore.1 bzless.1
+.ifdef USE_BZIP2
+.error You have `USE_BZIP2' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bzip2 ${PREFIX}/bin
${LN} -sf ${PREFIX}/bin/bzip2 ${PREFIX}/bin/bunzip2
diff --git a/archivers/unzip/Makefile b/archivers/unzip/Makefile
index 767294ce728c..dcbd2ce1a7d7 100644
--- a/archivers/unzip/Makefile
+++ b/archivers/unzip/Makefile
@@ -25,6 +25,10 @@ EXTRACT_ONLY= ${PORTNAME}550.tar.gz
MAKE_ENV= LOCAL_UNZIP="${CFLAGS} -DUSE_UNSHRINK -DUSE_SMITH_CODE"
.endif
+.ifdef USE_UNZIP
+.error You have `USE_UNZIP' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"