aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2016-06-27 01:13:04 +0800
committersunpoet <sunpoet@FreeBSD.org>2016-06-27 01:13:04 +0800
commit8c1292e535ab578062f7869430ed12c292cd9a34 (patch)
tree9dcc764be4e7c87b29ebe3ec4c6e6935fe1d4bd8 /archivers
parent3b6f515fc1233ef58d395cfa888ed1f42ac816e8 (diff)
downloadfreebsd-ports-gnome-8c1292e535ab578062f7869430ed12c292cd9a34.tar.gz
freebsd-ports-gnome-8c1292e535ab578062f7869430ed12c292cd9a34.tar.zst
freebsd-ports-gnome-8c1292e535ab578062f7869430ed12c292cd9a34.zip
- Update to 0.4.0
Changes: https://github.com/google/brotli/releases
Diffstat (limited to 'archivers')
-rw-r--r--archivers/brotli/Makefile3
-rw-r--r--archivers/brotli/distinfo5
-rw-r--r--archivers/brotli/files/patch-CVE-2016-162424
3 files changed, 4 insertions, 28 deletions
diff --git a/archivers/brotli/Makefile b/archivers/brotli/Makefile
index 7db5ad954ac9..46974d250714 100644
--- a/archivers/brotli/Makefile
+++ b/archivers/brotli/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= brotli
-PORTVERSION= 0.3.0
+PORTVERSION= 0.4.0
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= archivers
MAINTAINER= sunpoet@FreeBSD.org
diff --git a/archivers/brotli/distinfo b/archivers/brotli/distinfo
index 9950c10c1f06..e644c7597a00 100644
--- a/archivers/brotli/distinfo
+++ b/archivers/brotli/distinfo
@@ -1,2 +1,3 @@
-SHA256 (google-brotli-v0.3.0_GH0.tar.gz) = 5d49eb1a6dd19304dd683c293abf66c8a419728f4c6d0f390fa7deb2a39eaae2
-SIZE (google-brotli-v0.3.0_GH0.tar.gz) = 8035159
+TIMESTAMP = 1466891941
+SHA256 (google-brotli-v0.4.0_GH0.tar.gz) = 09aeea757c68a39feb0350a1506b5543ec5ce2c09988711d9e4dc1e9907dac7d
+SIZE (google-brotli-v0.4.0_GH0.tar.gz) = 8069842
diff --git a/archivers/brotli/files/patch-CVE-2016-1624 b/archivers/brotli/files/patch-CVE-2016-1624
deleted file mode 100644
index 781d1283e144..000000000000
--- a/archivers/brotli/files/patch-CVE-2016-1624
+++ /dev/null
@@ -1,24 +0,0 @@
-From 37a320dd81db8d546cd24a45b4c61d87b45dcade Mon Sep 17 00:00:00 2001
-From: eustas <eustas.ru@gmail.com>
-Date: Thu, 4 Feb 2016 15:35:44 +0100
-Subject: [PATCH] Fix possible pointer underflow
-
----
- dec/decode.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/dec/decode.c b/dec/decode.c
-index 920959c..892a254 100644
---- dec/decode.c
-+++ dec/decode.c
-@@ -1714,6 +1714,10 @@ static BROTLI_INLINE BrotliResult ProcessCommandsInternal(int safe,
- } else {
- const uint8_t *ringbuffer_end_minus_copy_length =
- s->ringbuffer_end - i;
-+ /* Check for possible underflow and clamp the pointer to 0. */
-+ if (PREDICT_FALSE(s->ringbuffer_end < (const uint8_t*)0 + i)) {
-+ ringbuffer_end_minus_copy_length = 0;
-+ }
- uint8_t* copy_src = &s->ringbuffer[
- (pos - s->distance_code) & s->ringbuffer_mask];
- uint8_t* copy_dst = &s->ringbuffer[pos];