aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-07-23 17:36:51 +0800
committerrafan <rafan@FreeBSD.org>2007-07-23 17:36:51 +0800
commitb028b113ef13fa7972bb45d681d7a0abe47c40a6 (patch)
treea76a27ca09341f754b493c264ee71c912a553d89 /archivers
parent855b1df39bc3a6f03abf878d9c99b5ba0838ba35 (diff)
downloadfreebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.tar.gz
freebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.tar.zst
freebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.zip
- Set --mandir and --infodir in CONFIGURE_ARGS if the configure script
supports them. This is determined by running ``configure --help'' in do-configure target and set the shell variable _LATE_CONFIGURE_ARGS which is then passed to CONFIGURE_ARGS. - Remove --mandir and --infodir in ports' Makefile where applicable Few ports use REINPLACE_CMD to achieve the same effect, remove them too. - Correct some manual pages location from PREFIX/man to MANPREFIX/man - Define INFO_PATH where necessary - Document that .info files are installed in a subdirectory relative to PREFIX/INFO_PATH and slightly change add-plist-info to use INFO_PATH and subdirectory detection. PR: ports/111470 Approved by: portmgr Discussed with: stas (Mk/*), gerald (info related stuffs) Tested by: pointyhat exp run
Diffstat (limited to 'archivers')
-rw-r--r--archivers/dpkg/Makefile5
-rw-r--r--archivers/gtar/Makefile3
-rw-r--r--archivers/gzip/Makefile2
-rw-r--r--archivers/libarchive/Makefile1
4 files changed, 3 insertions, 8 deletions
diff --git a/archivers/dpkg/Makefile b/archivers/dpkg/Makefile
index 0b324badde91..b254469203fd 100644
--- a/archivers/dpkg/Makefile
+++ b/archivers/dpkg/Makefile
@@ -30,9 +30,8 @@ PLIST_SUB+= DPKGDIR=${DPKGDIR:C,^/,,}
SUB_FILES= pkg-install pkg-deinstall
SUB_LIST+= DPKGDIR=${DPKGDIR}
-CONFIGURE_ARGS+=--with-admindir=${DPKGDIR} --mandir=${PREFIX}/man \
- --libdir=${PREFIX}/libexec --program-transform-name="" \
- --infodir=${PREFIX}/info --with-libintl-prefix=${LOCALBASE}
+CONFIGURE_ARGS+=--with-admindir=${DPKGDIR} --libdir=${PREFIX}/libexec \
+ --program-transform-name="" --with-libintl-prefix=${LOCALBASE}
MANLANG= "" de fr hu ja pl ru sv
diff --git a/archivers/gtar/Makefile b/archivers/gtar/Makefile
index 7490a23859b9..95a621cb5591 100644
--- a/archivers/gtar/Makefile
+++ b/archivers/gtar/Makefile
@@ -21,8 +21,7 @@ INFO= tar
USE_BZIP2= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-prefix=g \
- --infodir=${PREFIX}/${INFO_PATH}
+CONFIGURE_ARGS= --program-prefix=g
CONFIGURE_ENV= CPPFLAGS='-I${LOCALBASE}/include' \
LDFLAGS='-L${LOCALBASE}/lib ${LDSTATIC}' \
DEFAULT_ARCHIVE=/dev/sa0 \
diff --git a/archivers/gzip/Makefile b/archivers/gzip/Makefile
index f4c82486bd4c..e01bf6300c33 100644
--- a/archivers/gzip/Makefile
+++ b/archivers/gzip/Makefile
@@ -17,8 +17,6 @@ COMMENT= A compression utility designed to be a replacement for compress
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS+= --infodir=${LOCALBASE}/info \
- --mandir=${MANPREFIX}/man
MAN1= gunzip.1 gzexe.1 gzip.1 zcat.1 zcmp.1 zdiff.1 zforce.1 \
zgrep.1 zless.1 zmore.1 znew.1
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index ebf37353f5f1..d1ad2917b356 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -15,7 +15,6 @@ COMMENT= Library to create and read several streaming archive formats
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man
PLIST_FILES= bin/bsdtar \
include/archive.h \