aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2010-05-21 21:26:01 +0800
committerehaupt <ehaupt@FreeBSD.org>2010-05-21 21:26:01 +0800
commitb116edfc804101e073b918e4f69bc9380632aa10 (patch)
tree46a49c1d9448d88130b395c7c92a5bd4a0dcb42b /archivers
parent6ae6ad8dd79644d17243c2cb36cf9b5ede12a501 (diff)
downloadfreebsd-ports-gnome-b116edfc804101e073b918e4f69bc9380632aa10.tar.gz
freebsd-ports-gnome-b116edfc804101e073b918e4f69bc9380632aa10.tar.zst
freebsd-ports-gnome-b116edfc804101e073b918e4f69bc9380632aa10.zip
Update to 1.19
Diffstat (limited to 'archivers')
-rw-r--r--archivers/tardy/Makefile2
-rw-r--r--archivers/tardy/distinfo6
-rw-r--r--archivers/tardy/files/patch-common_error.cc10
-rw-r--r--archivers/tardy/files/patch-common_tar_output_filter_gzip.cc10
-rw-r--r--archivers/tardy/files/patch-libtardy__error.cc13
-rw-r--r--archivers/tardy/files/patch-libtardy__tar__output__filter__gzip.cc13
6 files changed, 30 insertions, 24 deletions
diff --git a/archivers/tardy/Makefile b/archivers/tardy/Makefile
index d4aa9bb0da4d..cb1a425ef41c 100644
--- a/archivers/tardy/Makefile
+++ b/archivers/tardy/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tardy
-PORTVERSION= 1.17
+PORTVERSION= 1.19
CATEGORIES= archivers
MASTER_SITES= SF
diff --git a/archivers/tardy/distinfo b/archivers/tardy/distinfo
index 2561fc6c278b..d5de1ead46af 100644
--- a/archivers/tardy/distinfo
+++ b/archivers/tardy/distinfo
@@ -1,3 +1,3 @@
-MD5 (tardy-1.17.tar.gz) = e20efbf1854269e620b7e052c09c19d5
-SHA256 (tardy-1.17.tar.gz) = b2058a1b43cd5060299dcd3bfc3f6240679b85419ee182af5160ae3d6aa09108
-SIZE (tardy-1.17.tar.gz) = 1693148
+MD5 (tardy-1.19.tar.gz) = 6f527b43df81e83713bcdb39860db3fa
+SHA256 (tardy-1.19.tar.gz) = 8e75cbc0bff738fa37862a1f41a80db439722d5b5dd44d80f38ab045563fb675
+SIZE (tardy-1.19.tar.gz) = 1719760
diff --git a/archivers/tardy/files/patch-common_error.cc b/archivers/tardy/files/patch-common_error.cc
deleted file mode 100644
index 84d69b3bec67..000000000000
--- a/archivers/tardy/files/patch-common_error.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- common/error.cc.orig Fri Jun 24 08:58:42 2005
-+++ common/error.cc Fri Jun 24 08:59:00 2005
-@@ -23,6 +23,7 @@
- #include <ac/assert.h>
- #include <ac/ctype.h>
- #include <ac/errno.h>
-+#include <sys/types.h>
- #include <ac/grp.h>
- #include <ac/pwd.h>
- #include <ac/stdarg.h>
diff --git a/archivers/tardy/files/patch-common_tar_output_filter_gzip.cc b/archivers/tardy/files/patch-common_tar_output_filter_gzip.cc
deleted file mode 100644
index 3ec9a027f607..000000000000
--- a/archivers/tardy/files/patch-common_tar_output_filter_gzip.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- common/tar/output/filter/gzip.cc.orig Fri Jun 24 09:17:36 2005
-+++ common/tar/output/filter/gzip.cc Fri Jun 24 09:17:57 2005
-@@ -26,6 +26,7 @@
- #include <ac/stdlib.h>
- #include <ac/string.h>
- #include <tar/output/filter/gzip.h>
-+#include <unistd.h>
-
- #ifndef Z_BUFSIZE
- #ifdef MAXSEG_64K
diff --git a/archivers/tardy/files/patch-libtardy__error.cc b/archivers/tardy/files/patch-libtardy__error.cc
new file mode 100644
index 000000000000..f519b6304137
--- /dev/null
+++ b/archivers/tardy/files/patch-libtardy__error.cc
@@ -0,0 +1,13 @@
+--- ./libtardy/error.cc.orig 2010-03-10 03:50:43.000000000 +0100
++++ ./libtardy/error.cc 2010-05-21 15:20:47.000000000 +0200
+@@ -33,6 +33,10 @@
+ #include <libtardy/mprintf.h>
+ #include <libtardy/progname.h>
+
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#endif
++
+
+ static void
+ error_get_id(int *uid, int *gid)
diff --git a/archivers/tardy/files/patch-libtardy__tar__output__filter__gzip.cc b/archivers/tardy/files/patch-libtardy__tar__output__filter__gzip.cc
new file mode 100644
index 000000000000..67ba1844e0e0
--- /dev/null
+++ b/archivers/tardy/files/patch-libtardy__tar__output__filter__gzip.cc
@@ -0,0 +1,13 @@
+--- ./libtardy/tar/output/filter/gzip.cc.orig 2010-03-10 03:50:43.000000000 +0100
++++ ./libtardy/tar/output/filter/gzip.cc 2010-05-21 15:20:02.000000000 +0200
+@@ -21,6 +21,10 @@
+ #include <libtardy/ac/string.h>
+ #include <libtardy/tar/output/filter/gzip.h>
+
++#ifdef __FreeBSD__
++#include <unistd.h>
++#endif
++
+ #ifndef Z_BUFSIZE
+ #ifdef MAXSEG_64K
+ #define Z_BUFSIZE 4096 // minimize memory usage for 16-bit DOS