aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-07-30 07:51:10 +0800
committerpav <pav@FreeBSD.org>2008-07-30 07:51:10 +0800
commitd421ea460fee3c2b2abbb6b6e5063d6bfe6eeea3 (patch)
tree8327f417c390d4a46e1e78aee73a08de11695363 /archivers
parente78a749770c23379d79e7a84bbb31752f6f84267 (diff)
downloadfreebsd-ports-gnome-d421ea460fee3c2b2abbb6b6e5063d6bfe6eeea3.tar.gz
freebsd-ports-gnome-d421ea460fee3c2b2abbb6b6e5063d6bfe6eeea3.tar.zst
freebsd-ports-gnome-d421ea460fee3c2b2abbb6b6e5063d6bfe6eeea3.zip
- Fix build with LIBSYNCE, LIBDYNAMITE, LIBUNSHIELD options enabled
- Fix pkg-config file - Change WWW - Bump PORTREVISION PR: ports/126063 Submitted by: Alexander Logvinov <ports@logvinov.com> (maintainer)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/liborange/Makefile15
-rw-r--r--archivers/liborange/pkg-descr2
2 files changed, 13 insertions, 4 deletions
diff --git a/archivers/liborange/Makefile b/archivers/liborange/Makefile
index ce3c407b5f8a..e206256e1d46 100644
--- a/archivers/liborange/Makefile
+++ b/archivers/liborange/Makefile
@@ -7,6 +7,7 @@
PORTNAME= liborange
PORTVERSION= 0.3.2
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= SF
MASTER_SITE_SUBDIR= synce
@@ -37,23 +38,26 @@ MAN1= orange.1
.if !defined(WITH_LIBSYNCE)
CONFIGURE_ARGS+= --without-libsynce
+REQUIRES+= libsynce
.else
LIB_DEPENDS+= synce.0:${PORTSDIR}/palm/synce-libsynce
-CONFIGURE_ARGS+= --with-libsynce=${LOCALBASE}
+CONFIGURE_ARGS+= --with-libsynce
.endif
.if !defined(WITH_LIBDYNAMITE)
CONFIGURE_ARGS+= --without-libdynamite
+REQUIRES+= libdynamite
.else
LIB_DEPENDS+= dynamite.0:${PORTSDIR}/archivers/libdynamite
-CONFIGURE_ARGS+= --with-libdynamite=${LOCALBASE}
+CONFIGURE_ARGS+= --with-libdynamite
.endif
.if !defined(WITH_LIBUNSHIELD)
CONFIGURE_ARGS+= --without-libunshield
+REQUIRES+= libunshield
.else
LIB_DEPENDS+= unshield.0:${PORTSDIR}/archivers/unshield
-CONFIGURE_ARGS+= --with-libunshield=${LOCALBASE}
+CONFIGURE_ARGS+= --with-libunshield
.endif
.if defined(WITH_INNO)
@@ -69,4 +73,9 @@ CONFIGURE_ARGS+= --enable-msi --with-libgsf
LIB_DEPENDS+= gsf-1.114:${PORTSDIR}/devel/libgsf
.endif
+post-patch:
+.for req in ${REQUIRES}
+ @${REINPLACE_CMD} -e 's|${req}||' ${WRKSRC}/${PORTNAME}.pc.in
+.endfor
+
.include <bsd.port.post.mk>
diff --git a/archivers/liborange/pkg-descr b/archivers/liborange/pkg-descr
index 22fdd4a03b78..85f75884809b 100644
--- a/archivers/liborange/pkg-descr
+++ b/archivers/liborange/pkg-descr
@@ -4,4 +4,4 @@ Windows.
Supported installers include VISE, InstallShield, Setup Factory and more.
-WWW: http://synce.sourceforge.net/
+WWW: http://www.synce.org/moin/