aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-02-24 13:27:41 +0800
committeredwin <edwin@FreeBSD.org>2003-02-24 13:27:41 +0800
commitdb62b47fa4214e30a42fe7615d788fd394634bb5 (patch)
treedfcae2d367617bc3d346263639d3aeee26bc545a /archivers
parent5eeaa5840923c17a01e19598913ae6928e46ba4b (diff)
downloadfreebsd-ports-gnome-db62b47fa4214e30a42fe7615d788fd394634bb5.tar.gz
freebsd-ports-gnome-db62b47fa4214e30a42fe7615d788fd394634bb5.tar.zst
freebsd-ports-gnome-db62b47fa4214e30a42fe7615d788fd394634bb5.zip
PEAR ports: handling PEAR's registry.
PEAR uses a "registry" to register installed modules, and this registry is initialized during the installation of mod_php4 (since 4.3.0). Unfortunately, installing PEAR modules through the ports does not maintain this registry. This PR fix this problem for the following ports: - sysutils/pear-Log - devel/pear-PEAR - devel/pear-Date - devel/pear-I18N - devel/pear-HTML_Common - devel/pear-HTML_Select_Common - security/pear-Crypt_CBC - mail/pear-Mail_Mime - net/pear-Net_Sieve - sysutils/pear-File - archivers/pear-Archive_Tar PR: ports/47921 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'archivers')
-rw-r--r--archivers/pear-Archive_Tar/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/archivers/pear-Archive_Tar/Makefile b/archivers/pear-Archive_Tar/Makefile
index c30a917e518e..7f0335e9a5d3 100644
--- a/archivers/pear-Archive_Tar/Makefile
+++ b/archivers/pear-Archive_Tar/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Archive_Tar
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= archivers www
MASTER_SITES= http://pear.php.net/get/
PKGNAMEPREFIX= pear-
@@ -29,7 +30,7 @@ PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
.else
PHP_BASE= ${LOCALBASE}
.endif
-
+PEAR= ${LOCALBASE}/bin/pear
LPHP_LIB= lib/php
PEARDIR= ${PHP_BASE}/${LPHP_LIB}
PLIST_SUB= PEARDIR=${LPHP_LIB}
@@ -47,4 +48,8 @@ do-install:
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
+post-install:
+# Register a new package
+ @${PEAR} upgrade -r -f ${WRKDIR}/package.xml
+
.include <bsd.port.post.mk>