aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-05-22 08:12:54 +0800
committermiwi <miwi@FreeBSD.org>2008-05-22 08:12:54 +0800
commite44c0bf0dd4f20db31ff34d5612f0999c3f8ea37 (patch)
treefa4ab94295f1ee5813b5760cbe25efdf57f28dc5 /archivers
parent3cc13b9ddef62f884fc207b49dbfc361eea96326 (diff)
downloadfreebsd-ports-gnome-e44c0bf0dd4f20db31ff34d5612f0999c3f8ea37.tar.gz
freebsd-ports-gnome-e44c0bf0dd4f20db31ff34d5612f0999c3f8ea37.tar.zst
freebsd-ports-gnome-e44c0bf0dd4f20db31ff34d5612f0999c3f8ea37.zip
The PHP_Archive package allows creation of self-contained cross-platform
PHP libraries or applications, similar to Java jar files. WWW: http://pear.php.net/package/PHP_Archive/ PR: ports/123832 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/pear-PHP_Archiv/Makefile47
-rw-r--r--archivers/pear-PHP_Archiv/distinfo3
-rw-r--r--archivers/pear-PHP_Archiv/pkg-descr4
4 files changed, 55 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index a8ba696ddf29..a43f92980335 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -101,6 +101,7 @@
SUBDIR += parchive
SUBDIR += pbzip2
SUBDIR += pear-File_Archive
+ SUBDIR += pear-PHP_Archiv
SUBDIR += pecl-bz2
SUBDIR += pecl-lzf
SUBDIR += pecl-phar
diff --git a/archivers/pear-PHP_Archiv/Makefile b/archivers/pear-PHP_Archiv/Makefile
new file mode 100644
index 000000000000..0f084e6c7c24
--- /dev/null
+++ b/archivers/pear-PHP_Archiv/Makefile
@@ -0,0 +1,47 @@
+# Ports collection makefile for: pear-PHP_Archive
+# Date created: 20 May 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PHP_Archive
+PORTVERSION= 0.11.4
+CATEGORIES= archivers
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Create and Use PHP Archive files
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+CATEGORY= PHP
+FILES= Archive.php Archive/Creator.php \
+ Archive/Exception.php Archive/Manager.php
+DATA= phar_frontcontroller.tpl
+TESTS= eof.phpt filenotfound.phpt filenotfound_phar.phpt \
+ filenotfoundtest.php gopearphar.php.inc \
+ longfilename.phpt makepearphar.php.inc \
+ maketestphars.php.inc new_phar.phar \
+ normalstat.phpt normalstat_phar.phpt \
+ opendir.phpt pearindex.php phar.log \
+ phpt_test.php.inc require_once.phpt \
+ require_once_phar.phpt savetest.php \
+ seek.phpt seek_phar.phpt streamstat.phpt \
+ streamstat_phar.phpt test.php test1.php \
+ test_path.php test_phar.phar \
+ test_phar2.phar test_require.php \
+ test_tar.tar twophars.phpt \
+ filenotfound/filenotfound.phar \
+ filenotfound/makefilenotfoundphar.php.inc \
+ longfilename/longphar.phar \
+ longfilename/makelongphar.php.inc \
+ opendir/makeopendirphar.php.inc \
+ opendir/opendir.phar \
+ planet_php/default_phar.php \
+ require_once/makerequire_oncephar.php.inc \
+ require_once/require_once.phar
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/archivers/pear-PHP_Archiv/distinfo b/archivers/pear-PHP_Archiv/distinfo
new file mode 100644
index 000000000000..b399f0fe4082
--- /dev/null
+++ b/archivers/pear-PHP_Archiv/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/PHP_Archive-0.11.4.tgz) = be6dfa685d559ed445b93e4706d4ca2a
+SHA256 (PEAR/PHP_Archive-0.11.4.tgz) = 8501d03ce5306633d00191c4d313bd056c4841c856e3748507885ef238772aef
+SIZE (PEAR/PHP_Archive-0.11.4.tgz) = 83047
diff --git a/archivers/pear-PHP_Archiv/pkg-descr b/archivers/pear-PHP_Archiv/pkg-descr
new file mode 100644
index 000000000000..be8c1b4964f2
--- /dev/null
+++ b/archivers/pear-PHP_Archiv/pkg-descr
@@ -0,0 +1,4 @@
+The PHP_Archive package allows creation of self-contained cross-platform
+PHP libraries or applications, similar to Java jar files.
+
+WWW: http://pear.php.net/package/PHP_Archive/