aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2016-01-28 03:02:32 +0800
committeracm <acm@FreeBSD.org>2016-01-28 03:02:32 +0800
commit0bc361a387b370d3e3fa7a7a7906e27e86008c41 (patch)
treea6630520db1b0c95e2010024c1ce3095f9edfa23 /archivers
parent9abf1720b3058493fb45461efe4381b7cf1a66a2 (diff)
downloadfreebsd-ports-gnome-0bc361a387b370d3e3fa7a7a7906e27e86008c41.tar.gz
freebsd-ports-gnome-0bc361a387b370d3e3fa7a7a7906e27e86008c41.tar.zst
freebsd-ports-gnome-0bc361a387b370d3e3fa7a7a7906e27e86008c41.zip
- Update to 5.9.1
- Fix build with FPC 3.0.0
Diffstat (limited to 'archivers')
-rw-r--r--archivers/peazip/Makefile7
-rw-r--r--archivers/peazip/distinfo4
-rw-r--r--archivers/peazip/files/patch-list_utils.pas11
-rw-r--r--archivers/peazip/files/patch-peach.pas64
-rw-r--r--archivers/peazip/files/patch-unit8.pas29
5 files changed, 104 insertions, 11 deletions
diff --git a/archivers/peazip/Makefile b/archivers/peazip/Makefile
index 27159fd5858e..5240334a5583 100644
--- a/archivers/peazip/Makefile
+++ b/archivers/peazip/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= peazip
-PORTVERSION= 5.7.1
+PORTVERSION= 5.9.1
CATEGORIES= archivers
MASTER_SITES= https://github.com/giorgiotani/PeaZip/releases/download/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -10,12 +10,11 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= acm@FreeBSD.org
COMMENT= Free archiver and file compressor
-BROKEN= fails with FPC 3.0.0
-
BUILD_DEPENDS= lazbuild:${PORTSDIR}/editors/lazarus \
fpcres:${PORTSDIR}/lang/fpc-utils
USES= dos2unix zip
+#USES= zip
USE_FPC= cairo fcl-base fcl-image pasjpeg rtl-objpas x11
USE_GNOME= #
@@ -25,7 +24,7 @@ DOS2UNIX_REGEX= .*\.([txt]|pas|lpi|txt)
LAZARUS_PROJECT_FILES= project_pea.lpi project_peach.lpi project_gwrap.lpi
LAZBUILD_CMD= ${LOCALBASE}/bin/lazbuild -d
LCL_UNITS_DIR= ${LOCALBASE}/share/lazarus-${LAZARUS_VER}/lcl/units/${BUILDNAME}
-LAZARUS_VER= 1.4.2
+LAZARUS_VER= 1.6RC2
LAZARUS_DIR= ${LOCALBASE}/share/lazarus-${LAZARUS_VER}
ARCHIVER_FILES= #
diff --git a/archivers/peazip/distinfo b/archivers/peazip/distinfo
index a93eeb434876..0dce76fcc040 100644
--- a/archivers/peazip/distinfo
+++ b/archivers/peazip/distinfo
@@ -1,2 +1,2 @@
-SHA256 (peazip-5.7.1.src.zip) = d32c1427f911a03974ee619096267eaf289afe4652f9abebbf18d55971b5e5f3
-SIZE (peazip-5.7.1.src.zip) = 4045028
+SHA256 (peazip-5.9.1.src.zip) = f5619179c72582898acf5dcf981b9c12f06646dc2d9039acbbc215af8f66f2ae
+SIZE (peazip-5.9.1.src.zip) = 4081923
diff --git a/archivers/peazip/files/patch-list_utils.pas b/archivers/peazip/files/patch-list_utils.pas
new file mode 100644
index 000000000000..8cae5dc79383
--- /dev/null
+++ b/archivers/peazip/files/patch-list_utils.pas
@@ -0,0 +1,11 @@
+--- list_utils.pas.orig 2016-01-27 13:31:39.038239000 -0500
++++ list_utils.pas 2016-01-27 13:32:00.045976000 -0500
+@@ -969,7 +969,7 @@
+ //name of the dir
+ ): integer;
+ var
+- s: utf8string;
++ s: string;
+ i, j: integer;
+ dirarr: array of utf8string;
+ begin
diff --git a/archivers/peazip/files/patch-peach.pas b/archivers/peazip/files/patch-peach.pas
index 060f2c9ad7ed..7b630a32ad2c 100644
--- a/archivers/peazip/files/patch-peach.pas
+++ b/archivers/peazip/files/patch-peach.pas
@@ -1,6 +1,6 @@
---- peach.pas.orig 2015-08-10 00:54:42.122935000 -0500
-+++ peach.pas 2015-08-10 00:56:11.788970000 -0500
-@@ -4320,6 +4320,7 @@
+--- peach.pas 2016-01-27 13:08:24.382120000 -0500
++++ peach.pas 2016-01-27 13:17:34.207034000 -0500
+@@ -4445,6 +4445,7 @@
APPLICATION5 = '';
APPLICATION6 = '';
APPLICATION7 = '';
@@ -8,7 +8,7 @@
{$ENDIF}
{$IFDEF NETBSD}
EXEEXT = '';
-@@ -4330,6 +4331,7 @@
+@@ -4455,6 +4456,7 @@
APPLICATION5 = '';
APPLICATION6 = '';
APPLICATION7 = '';
@@ -16,7 +16,7 @@
{$ENDIF}
{$IFDEF DARWIN}
EXEEXT = '';
-@@ -4340,6 +4342,7 @@
+@@ -4465,6 +4467,7 @@
APPLICATION5 = '';
APPLICATION6 = '';
APPLICATION7 = '';
@@ -24,3 +24,57 @@
{$ENDIF}
var
+@@ -6526,7 +6529,7 @@
+
+ procedure setdescription_advcustedit;
+ var
+- s:utf8string;
++ s:AnsiString;
+ sg:TStringGrid;
+ begin
+ sg:=Form_peach.StringGridCustedit1;
+@@ -6541,7 +6544,7 @@
+
+ procedure setdescription_custedit;
+ var
+- s:utf8string;
++ s:AnsiString;
+ begin
+ s:=Form_peach.StringGridCustedit.Cells[1,Form_peach.StringGridCustedit.Row];
+ if InputQuery(txt_description, '', s) then
+@@ -6553,7 +6556,7 @@
+
+ procedure editstring1_advcustedit;
+ var
+- s:utf8string;
++ s:AnsiString;
+ begin
+ s:=Form_peach.StringGridCustedit1.Cells[2,Form_peach.StringGridCustedit1.Row];
+ if InputQuery(txt_2_5_strbefore, '', s) then
+@@ -6566,7 +6569,7 @@
+
+ procedure editstring2_advcustedit;
+ var
+- s:utf8string;
++ s:AnsiString;
+ begin
+ s:=Form_peach.StringGridCustedit1.Cells[3,Form_peach.StringGridCustedit1.Row];
+ if InputQuery(txt_2_5_strafter, '', s) then
+@@ -6579,7 +6582,7 @@
+
+ procedure editstring3_advcustedit;
+ var
+- s:utf8string;
++ s:AnsiString;
+ begin
+ s:=Form_peach.StringGridCustedit1.Cells[4,Form_peach.StringGridCustedit1.Row];
+ if InputQuery(txt_3_3_stralt, '', s) then
+@@ -6592,7 +6595,7 @@
+
+ procedure editapp_custedit;
+ var
+- s:utf8string;
++ s:AnsiString;
+ begin
+ s:=Form_peach.StringGridCustedit.Cells[2,Form_peach.StringGridCustedit.Row];
+ if InputQuery(txt_edit, '', s) then
diff --git a/archivers/peazip/files/patch-unit8.pas b/archivers/peazip/files/patch-unit8.pas
new file mode 100644
index 000000000000..badf55485b97
--- /dev/null
+++ b/archivers/peazip/files/patch-unit8.pas
@@ -0,0 +1,29 @@
+--- unit8.pas.orig 2016-01-27 13:11:27.063394000 -0500
++++ unit8.pas 2016-01-27 13:14:04.758776000 -0500
+@@ -170,7 +170,7 @@
+ procedure new_pm;
+ var
+ i,rc:integer;
+- s:utf8string;
++ s:AnsiString;
+ begin
+ if InputQuery(txt_edit+' '+FormPM.mpw.Caption, '', s) then
+ begin
+@@ -190,7 +190,7 @@
+ end;
+
+ procedure editpw_pm;
+-var s:utf8string;
++var s:AnsiString;
+ begin
+ if FormPM.StringGridPM.Row=0 then
+ begin
+@@ -207,7 +207,7 @@
+ end;
+
+ procedure setdescription_pm;
+-var s:utf8string;
++var s:AnsiString;
+ begin
+ if FormPM.StringGridPM.Row=0 then
+ begin