aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2008-08-29 08:38:26 +0800
committeredwin <edwin@FreeBSD.org>2008-08-29 08:38:26 +0800
commit4bac4e417deefb29d6dc6ffa4d88e6a3410aeede (patch)
treec44c860d16b37e1ba49f3a495f80c73a3b59c4ad /archivers
parent51fd49c5b555f7163705883b2cb090e4bcdba22c (diff)
downloadfreebsd-ports-gnome-4bac4e417deefb29d6dc6ffa4d88e6a3410aeede.tar.gz
freebsd-ports-gnome-4bac4e417deefb29d6dc6ffa4d88e6a3410aeede.tar.zst
freebsd-ports-gnome-4bac4e417deefb29d6dc6ffa4d88e6a3410aeede.zip
The great "Unbreak archivers/lzo2" project - step 1
This patch doesn't unbreak it yet, but it increases the output of the test in which the port building hangs. I tried to build this port on the standard places (tb4.droso.net, my ports building jails) but couldn't reproduce it. So I'm waiting for this one to go through a run on i386 machines (http://portsmon.freebsd.org/portoverview.py?category=archivers&portname=lzo2 shows it once happens on i386) to fail and to get a pav or erwin email about it, which will at least show us where it goes wrong.
Diffstat (limited to 'archivers')
-rw-r--r--archivers/lzo2/Makefile12
-rw-r--r--archivers/lzo2/files/patch-util-check.sh11
2 files changed, 14 insertions, 9 deletions
diff --git a/archivers/lzo2/Makefile b/archivers/lzo2/Makefile
index 6c0c5a530003..6198c42db6a6 100644
--- a/archivers/lzo2/Makefile
+++ b/archivers/lzo2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lzo2
PORTVERSION= 2.03
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers devel
MASTER_SITES= http://www.oberhumer.com/opensource/lzo/download/ \
http://fresh.t-systems-sfr.com/unix/src/misc/ \
@@ -25,7 +25,7 @@ USE_LDCONFIG= yes
post-build:
@${ECHO_MSG} "===> Running self-tests for ${PKGNAME} (can take a few minutes, without output)"
- cd ${WRKSRC} && ${MAKE} test
+ cd ${WRKSRC} && ${MAKE} test SHELL="${SHELL} -x"
post-install:
.if !defined(NOPORTDOCS)
@@ -42,10 +42,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/examples/[a-z]*.[ch] ${EXAMPLESDIR}/
.endif
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == i386
-BROKEN= does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/archivers/lzo2/files/patch-util-check.sh b/archivers/lzo2/files/patch-util-check.sh
new file mode 100644
index 000000000000..4d25072a8dd0
--- /dev/null
+++ b/archivers/lzo2/files/patch-util-check.sh
@@ -0,0 +1,11 @@
+--- ./util/check.sh~ 2008-04-30 14:51:49.000000000 +0200
++++ ./util/check.sh 2008-07-29 11:00:31.000000000 +0200
+@@ -19,7 +19,7 @@
+
+ TMPFILE="/tmp/lzo_$$.tmp"
+ rm -f $TMPFILE
+-(find $dir/ -type f -print > $TMPFILE) || true
++find $dir/ -type f -print | tee $TMPFILE
+
+ ## methods=`$LZOTEST -m | sed -n 's/^ *-m\([0-9]*\).*/\1/p'`
+ ## methods="9721 9722 9723 9724 9725 9726 9727 9728 9729"