aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2014-09-19 22:08:10 +0800
committerjohans <johans@FreeBSD.org>2014-09-19 22:08:10 +0800
commit7bb6835a48c1abe47a67159517a5cf6c5cf670c9 (patch)
tree704f1aefeae9d3d7fd39149255ae923b11173e98 /archivers
parent6ba169e34b71896094a71f39af62100bc7a7a35c (diff)
downloadfreebsd-ports-gnome-7bb6835a48c1abe47a67159517a5cf6c5cf670c9.tar.gz
freebsd-ports-gnome-7bb6835a48c1abe47a67159517a5cf6c5cf670c9.tar.zst
freebsd-ports-gnome-7bb6835a48c1abe47a67159517a5cf6c5cf670c9.zip
- Use archivers/libarchive for FreeBSD < 10
- Bump portrevision Submitted by: John Hein <john.hein@microsemi.com>
Diffstat (limited to 'archivers')
-rw-r--r--archivers/rpm4/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index c91c3c4f0a53..e3138b4adf6b 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rpm
PORTVERSION= 4.12.0.1
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= http://rpm.org/releases/rpm-${PORTVERSION:R:R}.x/ \
ftp://ftp.mirrorservice.org/sites/ftp.rpm.org/pub/rpm/dist/rpm-${PORTVERSION:E}.x/
@@ -58,6 +59,12 @@ CONFIGURE_ENV+= LUA_CFLAGS=-I${LUA_INCDIR} \
LUA_LIBS="-L${LUA_LIBDIR} -llua-${LUA_VER} -lm"
PLIST_SUB+= VERSION=${PORTVERSION}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000000
+LIB_DEPENDS+= libarchive.so:${PORTSDIR}/archivers/libarchive
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's:\.\./\.\./bin/::' ${WRKSRC}/Makefile.in
${REINPLACE_CMD} -e 's/(hpux)/& || defined(__FreeBSD__)/' \
@@ -70,4 +77,4 @@ post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} librpm/html ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>