aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-03-27 04:35:55 +0800
committerantoine <antoine@FreeBSD.org>2014-03-27 04:35:55 +0800
commitbec806260dc64d6855a075f1e5d1effbd9ff73c3 (patch)
tree53ef077d86dacc51bc5efb0ae70950272a901842 /archivers
parentef57c6a8696742d2666973917f198711da6b60d4 (diff)
downloadfreebsd-ports-gnome-bec806260dc64d6855a075f1e5d1effbd9ff73c3.tar.gz
freebsd-ports-gnome-bec806260dc64d6855a075f1e5d1effbd9ff73c3.tar.zst
freebsd-ports-gnome-bec806260dc64d6855a075f1e5d1effbd9ff73c3.zip
Stage support
Diffstat (limited to 'archivers')
-rw-r--r--archivers/ocaml-zip/Makefile24
1 files changed, 5 insertions, 19 deletions
diff --git a/archivers/ocaml-zip/Makefile b/archivers/ocaml-zip/Makefile
index e4e253b25a82..3cf020afe084 100644
--- a/archivers/ocaml-zip/Makefile
+++ b/archivers/ocaml-zip/Makefile
@@ -16,36 +16,22 @@ USE_OCAML= yes
USE_OCAML_LDCONFIG=yes
USE_OCAML_WASH= yes
-NO_STAGE= yes
-
ALL_TARGET= all allopt
INSTALL_TARGET= install installopt
-MASTERPORT= ${PORTSDIR}/devel/ocaml-camlidl
PATTERN= ([[:space:]]*)cp([[:space:]]+.*)
-.include <bsd.port.pre.mk>
-
post-extract:
# PREFIX, CFLAGS and permissions safeness
@${REINPLACE_CMD} -E \
-e "s,${PATTERN},\1\$${BSD_INSTALL_DATA}\2," \
-e "s,(-ccopt[[:space:]])-g,\1\"${CFLAGS}\"," \
- -e "s,^(INSTALLDIR=).*,\1${OCAMLFIND_DESTDIR}/zip," \
+ -e "s,^(INSTALLDIR=).*,\1${STAGEDIR}${OCAMLFIND_DESTDIR}/zip," \
-e "/ldconf/d" ${WRKSRC}/Makefile
-pre-install:
-# For nonstandard prefixes
-.if !exists(${OCAMLFIND_DESTDIR})
- ${MKDIR} ${OCAMLFIND_DESTDIR}
-.endif
-.if !exists(${OCAMLFIND_LDCONF})
- ${TOUCH} ${OCAMLFIND_LDCONF}
-.endif
-
post-install:
- @${INSTALL_DATA} ${FILESDIR}/META ${OCAMLFIND_DESTDIR}/${PORTNAME}
- @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ ${INSTALL_DATA} ${FILESDIR}/META ${STAGEDIR}${OCAMLFIND_DESTDIR}/${PORTNAME}
+ @${FIND} ${STAGEDIR}${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
+ ${SED} "s,^${STAGEDIR}${PREFIX}/,," >> ${TMPPLIST}
@${ECHO_CMD} "@dirrm ${OCAML_SITELIBDIR}/${PORTNAME}" >> ${TMPPLIST}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>