aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorxmj <xmj@FreeBSD.org>2014-09-22 18:40:00 +0800
committerxmj <xmj@FreeBSD.org>2014-09-22 18:40:00 +0800
commitd39787ca07e42b7a91488f45cc6c58333ae10780 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /archivers
parent143e62b0f3ebf9f9c709e4c068013418325fc64c (diff)
downloadfreebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.tar.gz
freebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.tar.zst
freebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.zip
Update CentOS base to 6.5, add userland ports
The Fedora 10 infrastructure ports have been in use since June 2009 and, while having served a great deed, have become unsupported upstream and hence affected by unfixed security vulnerabilities. In addition to that, many recent Linux binaries need newer libc / stdlibc++ versions. This commit adds the linux-c6- userland as drop-in replacement for the -f10 infrastructure, as well as upgrading the linux_base-c6 port to CentOS 6.5. If you want to switch to linux-c6 ports, please define at /etc/make.conf: OVERRIDE_LINUX_BASE_PORT=c6 OVERRIDE_LINUX_NONBASE_PORTS=c6 Additionally, please add the following line to /etc/sysctl.conf: compat.linux.osrelease=2.6.18 Upgrading procedures are shown in /usr/ports/UPDATING. This work has been inspired by Artyom Mirgorodskiy's post to emulation@ in November 2013, using and extending mav@'s work. It has been tested extensively and most reported issues were already fixed. Please report any additional bug or "features" to the emulation mailing list. Many thanks to: mav@, rene@, allanjude@, netchild@, antoine@, everyone who's filed Issues and Pull requests on GitHub, PR: 186820 Differential Revision: https://reviews.freebsd.org/D793 Reviewed by: allanjude, antoine, bapt, rene Approved by: portmgr (antoine, bapt) Approved by: koobs (mentor) Sponsored by: Perceivon Hosting Inc.
Diffstat (limited to 'archivers')
-rw-r--r--archivers/linux-f10-ucl/Makefile6
-rw-r--r--archivers/linux-f10-upx/Makefile4
2 files changed, 2 insertions, 8 deletions
diff --git a/archivers/linux-f10-ucl/Makefile b/archivers/linux-f10-ucl/Makefile
index 8afeed7307ea..21747eaa4e5e 100644
--- a/archivers/linux-f10-ucl/Makefile
+++ b/archivers/linux-f10-ucl/Makefile
@@ -5,16 +5,14 @@ PORTNAME= ucl
PORTVERSION= 1.03
CATEGORIES= archivers linux
MASTER_SITES= CRITICAL/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
-PKGNAMEPREFIX= linux-f10-
-DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
MAINTAINER= emulation@FreeBSD.org
COMMENT= UCL, a lossless data compression library (Linux Fedora 10)
CONFLICTS= linux-ucl-[0-9]* linux-f8-ucl-[0-9]*
+USE_LINUX= f10
USE_LINUX_RPM= yes
-LINUX_DIST_VER= 10
RPMVERSION= 8.fc9
USE_LDCONFIG= yes
@@ -23,6 +21,4 @@ DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
PORTDOCS= COPYING NEWS README THANKS TODO
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/archivers/linux-f10-upx/Makefile b/archivers/linux-f10-upx/Makefile
index 83eb22afae17..cd2f9676b4e0 100644
--- a/archivers/linux-f10-upx/Makefile
+++ b/archivers/linux-f10-upx/Makefile
@@ -13,9 +13,9 @@ COMMENT= UPX, a high-performance executable packer (Linux Fedora 10)
CONFLICTS= linux-upx-[0-9]* linux-f8-upx-[0-9]*
+USE_LINUX= f10
USE_LINUX_RPM= yes
USE_LINUX_APPS= ucl
-LINUX_DIST_VER= 10
RPMVERSION= 1.fc10
BRANDELF_FILES= usr/bin/upx
@@ -25,6 +25,4 @@ PORTDOCS= BUGS COPYING LICENSE NEWS PROJECTS README README.1ST \
THANKS TODO elf-to-mem.txt filter.txt loader.txt selinux.txt
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>