aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-04 08:57:08 +0800
committeredwin <edwin@FreeBSD.org>2002-11-04 08:57:08 +0800
commite2eeb7de374021ca414336f5a523ecc8eac6935c (patch)
tree1873cd6f91f0e0cdba1f4150a34d8d0c90280d42 /archivers
parent0d059aa4abcbd5ee71af804ff6fba027aaa2fe51 (diff)
downloadfreebsd-ports-gnome-e2eeb7de374021ca414336f5a523ecc8eac6935c.tar.gz
freebsd-ports-gnome-e2eeb7de374021ca414336f5a523ecc8eac6935c.tar.zst
freebsd-ports-gnome-e2eeb7de374021ca414336f5a523ecc8eac6935c.zip
PERL -> REINPLACE
Noticed by: bento
Diffstat (limited to 'archivers')
-rw-r--r--archivers/ha/Makefile3
-rw-r--r--archivers/hpack.non-usa.only/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/archivers/ha/Makefile b/archivers/ha/Makefile
index 4efa687286a5..982c3e6ca4c2 100644
--- a/archivers/ha/Makefile
+++ b/archivers/ha/Makefile
@@ -18,9 +18,10 @@ NO_WRKSUBDIR= yes
MAKEFILE= makefile.nix
ALL_TARGET= ha
USE_GMAKE= yes
+USE_REINPLACE= yes
pre-patch:
- @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/c/hsc.c ${WRKSRC}/c/cpy.c \
${WRKSRC}/c/asc.c
diff --git a/archivers/hpack.non-usa.only/Makefile b/archivers/hpack.non-usa.only/Makefile
index 39407ff2ca57..02ff2eb232ff 100644
--- a/archivers/hpack.non-usa.only/Makefile
+++ b/archivers/hpack.non-usa.only/Makefile
@@ -18,10 +18,11 @@ MAKEFILE= makefile
ALL_TARGET= freebsd
INSTALL_TARGET= freebsd.install
MAN1= hpack.1
+USE_REINPLACE= yes
post-patch:
.for f in language/language.c cli.c
- @${PERL} -pi -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/${f}
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/${f}
.endfor
post-install: