aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-07-21 03:56:26 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-07-21 03:56:26 +0800
commitfd639cd3afae613ce752e2298bdcb1ec1feaeec8 (patch)
tree6375c1fcdcdf180bfdbcfd5271efd8a0f308f984 /archivers
parent2dbcfa15093356144484fd3218e6193ae9dad804 (diff)
downloadfreebsd-ports-gnome-fd639cd3afae613ce752e2298bdcb1ec1feaeec8.tar.gz
freebsd-ports-gnome-fd639cd3afae613ce752e2298bdcb1ec1feaeec8.tar.zst
freebsd-ports-gnome-fd639cd3afae613ce752e2298bdcb1ec1feaeec8.zip
- Add archivers/lhasa
Lhasa is a command line tool and library for parsing LHA archives. Currently it is only possible to decompress archives. Compressing LHA archives may be an enhancement for future versions. The aim is to be compatible with as many different variants of the LHA file format as possible, including LArc (.lzs) and PMarc (.pma). The command line tool aims to be interface-compatible with Unix LHA tool (command line syntax and output), for backwards compatibility with tools that expect particular output. WWW: http://fragglet.github.io/lhasa/ PR: 211177 Submitted by: cs@innolan.dk
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/lhasa/Makefile34
-rw-r--r--archivers/lhasa/distinfo3
-rw-r--r--archivers/lhasa/pkg-descr12
-rw-r--r--archivers/lhasa/pkg-plist12
5 files changed, 62 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 592013336e93..c751f692ab0a 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -55,6 +55,7 @@
SUBDIR += lcab
SUBDIR += lha
SUBDIR += lha-ac
+ SUBDIR += lhasa
SUBDIR += libarc
SUBDIR += libarchive
SUBDIR += libcabinet
diff --git a/archivers/lhasa/Makefile b/archivers/lhasa/Makefile
new file mode 100644
index 000000000000..9cf50308214d
--- /dev/null
+++ b/archivers/lhasa/Makefile
@@ -0,0 +1,34 @@
+# Created by: Carsten Larsen <cs@innolan.dk>
+# $FreeBSD$
+
+PORTNAME= lhasa
+PORTVERSION= 0.3.1
+CATEGORIES= archivers
+MASTER_SITES= https://soulsphere.org/projects/lhasa/ \
+ http://suyai.innolan.net/
+
+MAINTAINER= cs@innolan.dk
+COMMENT= Command line tool and library for parsing LHA archives
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= autoreconf pathfix libtool
+PATHFIX_MAKEFILEIN= Makefile.am
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= --disable-silent-rules \
+ --program-suffix=sa
+INSTALL_TARGET= install-strip
+
+PORTDOCS= ChangeLog README AUTHORS TODO NEWS
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/archivers/lhasa/distinfo b/archivers/lhasa/distinfo
new file mode 100644
index 000000000000..50a197e54cc3
--- /dev/null
+++ b/archivers/lhasa/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1468768769
+SHA256 (lhasa-0.3.1.tar.gz) = 3fb08e5f85a9b9dd023922896be9157d5fb5c0448424681810aaa2b0558a5f24
+SIZE (lhasa-0.3.1.tar.gz) = 2933084
diff --git a/archivers/lhasa/pkg-descr b/archivers/lhasa/pkg-descr
new file mode 100644
index 000000000000..a1dc5954c657
--- /dev/null
+++ b/archivers/lhasa/pkg-descr
@@ -0,0 +1,12 @@
+Lhasa is a command line tool and library for parsing LHA archives.
+
+Currently it is only possible to decompress archives. Compressing
+LHA archives may be an enhancement for future versions. The aim is
+to be compatible with as many different variants of the LHA file
+format as possible, including LArc (.lzs) and PMarc (.pma).
+
+The command line tool aims to be interface-compatible with Unix LHA
+tool (command line syntax and output), for backwards compatibility
+with tools that expect particular output.
+
+WWW: http://fragglet.github.io/lhasa/
diff --git a/archivers/lhasa/pkg-plist b/archivers/lhasa/pkg-plist
new file mode 100644
index 000000000000..b60ef622a4b6
--- /dev/null
+++ b/archivers/lhasa/pkg-plist
@@ -0,0 +1,12 @@
+bin/lhasa
+include/liblhasa-1.0/lha_decoder.h
+include/liblhasa-1.0/lha_file_header.h
+include/liblhasa-1.0/lha_input_stream.h
+include/liblhasa-1.0/lha_reader.h
+include/liblhasa-1.0/lhasa.h
+lib/liblhasa.a
+lib/liblhasa.so
+lib/liblhasa.so.0
+lib/liblhasa.so.0.0.0
+libdata/pkgconfig/liblhasa.pc
+man/man1/lhasa.1.gz