aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-03-09 03:48:41 +0800
committermat <mat@FreeBSD.org>2018-03-09 03:48:41 +0800
commit3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /archivers
parentbd4297a179c7edf0fe5800bb82c677771f17923c (diff)
downloadfreebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.tar.gz
freebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.tar.zst
freebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Diffstat (limited to 'archivers')
-rw-r--r--archivers/pear-File_Archive/Makefile10
-rw-r--r--archivers/pear-Horde_Compress/Makefile1
-rw-r--r--archivers/pear-Horde_Compress_Fast/Makefile1
-rw-r--r--archivers/pear-Horde_Pack/Makefile1
-rw-r--r--archivers/php-horde_lz4/Makefile2
-rw-r--r--archivers/php-snappy/Makefile2
6 files changed, 7 insertions, 10 deletions
diff --git a/archivers/pear-File_Archive/Makefile b/archivers/pear-File_Archive/Makefile
index 7cd4280d8bbd..50e8916b9679 100644
--- a/archivers/pear-File_Archive/Makefile
+++ b/archivers/pear-File_Archive/Makefile
@@ -8,8 +8,8 @@ CATEGORIES= archivers www pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= PEAR class to manipulate tar, gz, tgz, bz2, tbz, zip, ar (deb) files
-BUILD_DEPENDS= ${PEARDIR}/MIME/Type.php:mail/pear-MIME_Type
-RUN_DEPENDS= ${PEARDIR}/MIME/Type.php:mail/pear-MIME_Type
+BUILD_DEPENDS= ${PEARDIR}/MIME/Type.php:mail/pear-MIME_Type@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/MIME/Type.php:mail/pear-MIME_Type@${PHP_FLAVOR}
USES= pear php
NO_ARCH= yes
@@ -22,8 +22,8 @@ PEAR_MAIL_DESC= PEAR::Mail support
PEAR_MAIL_MIME_DESC= PEAR::Mail_Mime support
PEAR_CACHE_LITE_DESC= PEAR::Cache_Lite support
-PEAR_MAIL_RUN_DEPENDS= ${PEARDIR}/Mail.php:mail/pear-Mail
-PEAR_MAIL_MIME_RUN_DEPENDS= ${PEARDIR}/Mail/mime.php:mail/pear-Mail_Mime
-PEAR_CACHE_LITE_RUN_DEPENDS+= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite
+PEAR_MAIL_RUN_DEPENDS= ${PEARDIR}/Mail.php:mail/pear-Mail@${PHP_FLAVOR}
+PEAR_MAIL_MIME_RUN_DEPENDS= ${PEARDIR}/Mail/mime.php:mail/pear-Mail_Mime@${PHP_FLAVOR}
+PEAR_CACHE_LITE_RUN_DEPENDS+= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite@${PHP_FLAVOR}
.include <bsd.port.mk>
diff --git a/archivers/pear-Horde_Compress/Makefile b/archivers/pear-Horde_Compress/Makefile
index c987a92f1dc3..bb5210eb1879 100644
--- a/archivers/pear-Horde_Compress/Makefile
+++ b/archivers/pear-Horde_Compress/Makefile
@@ -3,7 +3,6 @@
PORTNAME= Horde_Compress
PORTVERSION= 2.2.1
CATEGORIES= archivers www pear
-PKGNAMEPREFIX= pear-
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde Compression API
diff --git a/archivers/pear-Horde_Compress_Fast/Makefile b/archivers/pear-Horde_Compress_Fast/Makefile
index 026a2401462d..50c5fb6d50b3 100644
--- a/archivers/pear-Horde_Compress_Fast/Makefile
+++ b/archivers/pear-Horde_Compress_Fast/Makefile
@@ -3,7 +3,6 @@
PORTNAME= Horde_Compress_Fast
PORTVERSION= 1.1.1
CATEGORIES= archivers www pear
-PKGNAMEPREFIX= pear-
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde Fast Compression Library
diff --git a/archivers/pear-Horde_Pack/Makefile b/archivers/pear-Horde_Pack/Makefile
index c60836f1d7d8..e8a2157769f1 100644
--- a/archivers/pear-Horde_Pack/Makefile
+++ b/archivers/pear-Horde_Pack/Makefile
@@ -3,7 +3,6 @@
PORTNAME= Horde_Pack
PORTVERSION= 1.0.7
CATEGORIES= archivers www pear
-PKGNAMEPREFIX= pear-
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde Pack Utility
diff --git a/archivers/php-horde_lz4/Makefile b/archivers/php-horde_lz4/Makefile
index b18e55f8320c..b73e289565ce 100644
--- a/archivers/php-horde_lz4/Makefile
+++ b/archivers/php-horde_lz4/Makefile
@@ -5,7 +5,7 @@ PORTNAME= horde_lz4
PORTVERSION= 1.0.10
CATEGORIES= archivers pear
MASTER_SITES= http://pear.horde.org/get/
-PKGNAMEPREFIX= php-
+PKGNAMEPREFIX= ${PECL_PKGNAMEPREFIX}
DIST_SUBDIR= PECL
MAINTAINER= mm@FreeBSD.org
diff --git a/archivers/php-snappy/Makefile b/archivers/php-snappy/Makefile
index 36d73c43b52c..63c8df5ced5b 100644
--- a/archivers/php-snappy/Makefile
+++ b/archivers/php-snappy/Makefile
@@ -4,7 +4,7 @@
PORTNAME= snappy
PORTVERSION= 0.1.9
CATEGORIES= archivers
-PKGNAMEPREFIX= php-
+PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
MAINTAINER= joneum@FreeBSD.org
COMMENT= PHP extension for the snappy compression algorithm